0

I installed Tranmission on my Pi3 today, mainly following this post: Permission problems with Transmission. I finally got it working I thought, but now I ran into something weird.

From the Pi3 side everything seems to be working. Downloads initiate and are written and moved arround, even my sabnzbd installation downloaded a test file and transfered it to the 'completed' directory:

pi@raspberrypi:/mnt/synology/TORRENTS $ ls -la
total 20
drwxr-xr-x 5 pi pi 4096 Oct 20 17:47  .
drwxr-xr-x 3 pi pi 4096 Oct 20 13:23  ..
drwxr-xr-x 2 pi pi 4096 Oct 20 17:47  INCOMPLETE
drwxr-xr-x 2 pi pi 4096 Oct 20 14:30 'BlaBlaBla.720p.WEB-DL.EN-SUB.x264'
drwxr-xr-x 2 pi pi 4096 Oct 20 17:58  test_download_100MB

But when I check the share in Windows or in the Synology file browser none of the downloaded files are there.

Can somebody enlighten me on what is happening here and how I can make these files visible for Windows and Synology?

I've just gotten my feet wet when it comes to Linux, so please don't be too concise and elaborate. Thanks in advance

  • Pretty sure you need to add some software to Windows in order for it to read NFS. – goldilocks Oct 20 at 21:48
  • Windows 10 Pro supports NFS if you enable it. Which Windows version do you have – Jaromanda X Oct 21 at 8:25
  • @goldilocks Indeed, but I still don't understand why the the DSM file browser cannot see the files. DSM understands NFS out of the box, right?. It's the other way arround too: files and folders created from my Windows PC or from the DSM file browser are not visible to the Pi3. I can even make a folder called 'TORRENT' on the PI3 and make a folder 'TORRENT' in the DSM file browser in the same share without getting a conflict. – FenderBender Oct 21 at 9:01
  • Could it be because DSM has no clue as to who user pi:pi is? (Sorry if this sounds stupid, am learning as I go here and I'am just getting started) – FenderBender Oct 21 at 9:40
  • 1
    Please just write an answer. That will finish the question and show others that is has a solution. Seems you can just move your comment with the solution into the answer field. It is nothing wrong with answering the own question. – Ingo Oct 21 at 17:57
1

Finally found what went wrong. I made an error in the path of the mount target, so the files never reached the share, they were just somewhere on the sdcard of the Pi. But when I corrected the error, I got a new NFS error. Couldn't solve that one, so had another go as to why my CIFS entry in /etc/fstab worked fine in the CLI, but continued to have Permission Denied error in Transmission. Turns out I had the vers=3.0 option specified, which aparently Transmission did not like at all. When I removed that everything worked just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.