0

I made a configuration with this config : 2 WLAN, 2 SSID, Dongle + integrated wifi on Raspberry PI 3B+

Everything is working except, not everybody cannot connect to the wifi. Samsung Smartphone cannot connect to this and some Windows 10 too. What can be the problem. Any idea? This is my WPA_SUPPLICANT CONFIG: network={ mode=2 ssid="Work" psk="Password01" frequency=2412 proto=RSN key_mgmt=WPA-PSK pairwise=CCMP group=CCMP auth_alg=OPEN }.

The SSID work and it is visible. Nothing appear, is like a loop, the user click on the SSID WORK and the device said, connecting... after a while the connection process stop and again connecting. For Windows 10. It says, Unable to connect to this network.

2
  • What errors or messages do you see when users fail to connect? Can they even see the SSID? Oct 21, 2019 at 12:34
  • @RogerJones, the SSID work and it is visible. Nothing appear, is like a loop, the user click on the SSID WORK and the device said, connecting... after a while the connection process stop and again connecting. For Windows 10. It says, Unable to connect to this network.
    – Pi3.14
    Oct 21, 2019 at 14:59

2 Answers 2

1

I use this /etc/wpa_supplicant/wpa_supplicant.conf:

country=DE
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
    ssid="RPiNet"
    mode=2
    key_mgmt=WPA-PSK
    psk="verySecretPassword"
    frequency=2412   # channel 1
}

and my Samsung smartphone connects to the RasPi without any problems. You have to configure the Samsung WiFi using the "verySecretPassword" and to use DHCP. Do you configure it? I have also seen that sometimes a 4 character password was to short. You should use at least 8 character.

You can try to delete the line key_mgmt=WPA-PSK in the hope that wpa_supplicant will then use the right encryption. By default WPA2 (resp. RSN) is used instead of older WPA. With a line proto=RSN WPA you can define that WPA should be used if RSN isn't accepted.

2
  • I tried, even changing the country by DE because before it was BE (Belgium) but it does not change. i do not know why ? I will try with another dongle Wifi, this afternoon, I used a TP-Link TL-WN725N. I even tried to do a hotspot (no password) , samsung device can connect but no internet. i do not know why
    – Pi3.14
    Oct 22, 2019 at 8:57
  • i tried with RASPAP raspap.com and it works but i cannot have 2SSID :(. or maybe if i modify hostapd.conf. mmh ...
    – Pi3.14
    Oct 22, 2019 at 15:21
0

This could be a false positive, but the symptoms (unspecific as they are) match up with the answer I provided here.

In short, it seems some clients fail to connect unless you disable WPA2 with proto=wpa, or wpa_supplicant is replaced with something that provides an WPA2 Authenticator like hostapd.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.