0

Yesterday I made a Nas Server on Raspberry Pi and on the local network it's works fine and the SSH connection too but as soon as I try to connect to the Raspberry through Putty from an outside network it's not working.

I set a static IP for Raspberry and I port forwarded port 22 to the static IP but in the port checker it' s still closed.

I checked the ports on the Raspberry too and it says: "Listen" to port 22.

I have a ZTE f608 router.

I don't know what to do. If you guys have any ideas please share with me. Thank you.

  • This question does not belong to Raspberry Pi. You should better ask at superuser.com – Ingo Oct 21 at 19:22
2

You could try a port translation in your router’s settings. Say port 22222 from any public IP mapped to port 22 on the Pi’s local IP. Pick any valid port number above 1024. 22222 is just too obvious as an example. You will have to add the chosen port to the ssh command: ssh -p 22222 .... (I didn’t check that syntax. Look it up.)

1

Some ISPs apply port limitations on private internet connections. This is to prevent novice users from possibly harmful network settings.
You will have to ask your ISP about such limitations.
If that is the case you will not get around getting an commercial internet contract where no such limitation exists.

For instance in germany Vodafone does not even allow outbound connections to an SMB/CIFS share not even thinking about inbound limitations. It just blocks the assigned port completely.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.