2

I've configured my Raspberry Pi so I can connect to SSH, and the first few days it worked flawlessly. Now yesterday and today, I couldn't connect to it so I tried to ping it. I kept getting:

Pinging 169.254.1.1 with 32 bytes of data:
Reply from 169.254.199.212: Destination host unreachable.

I've tried from another laptop and the other laptop can SSH/PING perfectly (The only difference that I could see is that the other laptop has Windows 7).

My firewall is disabled, I haven't modified anything since it worked. Also I've checked if there are different setting on my laptop then on the other but they all seem the same.

EDIT: Also another few thing to mention if they are useful: My Pi isn't connected to Wi-Fi. I've tried disabling the laptop's Wi-Fi but it still didn't work.

  • Did you configure your Raspberry Pi to have a static IP? – syb0rg Nov 2 '13 at 16:09
  • Yes, I've set it to 169.254.1.1 and as I've mentioned before it worked before and still works on another laptop. – user104289 Nov 2 '13 at 19:20
  • So you are saying the Pi works perfectly and can be ssh'd into but only from one machine? Can the problem machine (What version of Windows?) see anything else on your network? Like the Windows 7 machine that can connect? via Ping. Are you using putty or something else to ssh? Does it have a certificate store that you can clear? – rob Nov 3 '13 at 21:43
  • The information you are giving us is actually not enough to solve the problem. You are saying that there is no difference between the 2 laptops except for that the other one has Windows 7 which probably isn't the problem. We actually don't have enough information to figure this out. Are you sure the laptop is connected with the same network?(just desperately trying to help) – Loko Jan 21 '14 at 13:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.