1

I have a Raspberry Pi 4 that allows me to VPN into my home network. I used PiVPN to setup the Pi as an OpenVPN server and create clients. I managed to setup a PC with the config file I got from the Pi and I can remote into the network. However, I cannot get access to the cameras when I type the IP address assigned to the NVR. When I connect back to my home network, I'm able to see the NVR again, but never when I'm connected to an outside network (cell phone hotspot) and using a VPN. My public IP matches the home network, so I know it's working and I'm able to access my router's settings page from the VPN connection. On my NVR, I have DHCP enabled and it picks up the information automatically (ip address, gateway, dns). My assigned IP address on VPN is 10.8.0.2, which is completely different from the devices IP on my home network (192.1.168.x). I thought maybe that was related to the issue, but I'm not really sure about this.

What is the issue? How can I fix this? Setting up the VPN took me 10 minutes and troubleshooting how to view my cameras has taken way longer.

This question is different from my other OpenVPN question. That issue involved OpenVPN not working over Ethernet when I installed PiVPN over WiFi. I reinstalled PiVPN using my Ethernet connection and it works now. The problem I’m dealing with is not being able to view my cameras even though I can get connected to my VPN and use the internet.

  • 1
    Possible duplicate of PiVPN - OpenVPN Setup issues – Milliways Oct 23 at 2:52
  • Why do you ask again? On your other question I asked you in a comment to give some additional information but you don't do it. Why should I help you if you are not supporting to find a solution? B.t.w. it is a good idea to take the short Tour and visit the Help Center to get an idea how things work here. – Ingo Oct 23 at 10:32
  • I’m not sure why I should bother getting your help Ingo considering this is a different question and instead of kindly pointing out that you need the same information that you requested in my earlier different question, you have chosen to reply as a pompous jerk. No thanks, I don’t want your help anyway. – Jay P Oct 23 at 15:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.