4

I bought a Raspberry Pi and installed Raspbian and transmission. I want to connect my USB hard drive to save there the transmission's downloads. The HDD is formatted in FAT32, Windows recognizes it correctly. When I try to mount it in /dev/sda1 it prompts me:

mount: special device /dev/sda1 does not exists

fdisk finds only /dev/mmcblk0p1 and /dev/mmcblk0p2.

I also tried adding

/dev/sda1      /mnt/usb     vfat      uid=pi,gid=pi     0     0

to my /etc/fstab.

Can someone help me?

I tried mounting an NTFS-formatted USB flash drive and it mounts correctly.

2

Is the disk powering up? A USB HDD may require lots of current. I suggest you use a powered USB hub for the disk.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • I tried with another HDD (FAT32) alimented, and it works fine. The fact is the don't-working HDD powers up when I turn on the Raspberry, but I'm not able to mount it. My 3.0 HDD, instead, doesn't even power up. In the afternoon I'm buying a powered USB hub then. – Federico Nov 3 '13 at 12:34
  • Can you post the output of 'dmesg' and 'cat /var/log/syslog' ? – iceman Nov 5 '13 at 14:42
1

Occasionally I get windows USB storage devices that do not have a "1st" partition and have to be mounted without the partition specifier so in fstab I have

/dev/sdc        /mnt/sdc    auto        user,noatime        0 1
/dev/sdc1       /mnt/sdc1   auto        user,noatime        0 1

and mount them with either

mount /mnt/sdc1

or

mount /mnt/sdc

if /dev/sdc1 does not exist.

0

Run sudo blkid and if you can't see your HDD that's mean it still not powered up. The Pi's USB ports only have output ~500mA as default so it might not enough for your HDD.

In this case you have to increase current output of those USB ports. Add max_usb_current=1 to /boot/config.txt then reboot the Pi :)

  • I advise against maxing the current to the USB ports, a powered USB hub is a much better option. – Darth Vader May 8 '16 at 18:02
  • with this specific case : Raspbian + Transmission + one HDD. I cant see why it shouldn't. That HDD may draw more than 1.2A? Probably not :) – Huy.PhamNhu May 8 '16 at 18:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.