So I tried to make an ssh connection with my raspberrypi (running raspbian ) over ethernet. This used to work but somehow it doesn't anymore. I think the issue is that my raspberry pi can't get an ipadress, but how do I fix this? I have tried to clear the cache and all but with no success. Anyone ideas?

  • The raspi fetches the IP address from a DHCP server, if you configured the raspi to use dhcp. I see two possibilities why this doesn't work anymore. 1st your reconfigured the raspi not to use DHCP, or 2nd your DHCP server (Internet-Router, or whatever) is down or does not accept the raspis MAC asdress for any reason. Oct 29, 2019 at 16:29
  • What IP address does your Pi have and what IP address does the computer you're connecting from have? Can they ping each other?
    – Fred
    Nov 2, 2019 at 9:18

1 Answer 1


Because you guess that the RasPi may not get an ip address I assume that you are using a DHCP server on your network. Depending on the network environment it may be possible the pool of ip addresses, reserved to give to devices, is used up. Check your DHCP server and if required increase the pool for reserved ip addresses.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.