0

I've been working on getting a Home automation project going for a while, using a Rasp pi 1b (26 pin header). This is a well trodden path by others, as it is a project to control status remote sockets: https://securipi.co.uk/remote-433-receivers.pdf

I have been trying for around a couple of weeks to get the transmission side of the project working-to no avail. I have successfully sniffed the unique code, gap and t0/t1 values sent by the remote which came with the sockets, using both Python rpi-rf and pigpio. In terms of hardware I have a separate heterodyne receiver and transmitter and also the cheaper ones which tend to have a shorter range.

Others resources and successful projects I've used to verify what I'm doing are:

https://hackernoon.com/diy-home-automation-fan-control-with-raspberry-pi-3-rf-transmitter-and-homebridge-59ad24845770

http://www.piddlerintheroot.com/rf-433-mhz/

I'm using a pigpio python script to replay the codes, but have been unsuccessful in activating a socket. I've also tried transmission via the python rpi-rf scripts. Also to no avail .

Has anyone a suggestion of how I can verify if the transmitter is working, using the equipment I have mentioned? I attempted to use pilight-debug, but could not get it to build - segmentation fault on rasp pi 2.

update 1st Nov I've now had partial success, following soldering a antenna onto the heterodyne transmitter I have. Here are the codes I sniffed from the socket remote, which I am unable to retrieve using pigpio at present. So I used the Python rpi-rf modules and the scripts provided to received and send data.

The codes sniffed from the socket remote are: - 2019-11-01 22:17:52 - [INFO] rpi-rf_receive: 3268719 [pulselength 304, protocol 1]

And on replay from the heterodyne transmitter the resulting receive from the above was: 2019-11-01 22:43:34 - [INFO] rpi-rf_receive: 3268719 [pulselength 136, protocol 3] 2019-11-01 22:43:34 - [INFO] rpi-rf_receive: 3268719 [pulselength 135, protocol 3] 2019-11-01 22:43:34 - [INFO] rpi-rf_receive: 3268719 [pulselength 135, protocol 3]

The socket did not switch on from the above replay.

I disconnected the receiver connected to the Pi, before attempting the transmission from the Pi transmitter. Probably also worth mentioning that the receiver and transmitter are connected to different rasp pi's.

Any suggestions as to why the socket will not activate, given what should be the same waveform generated by the Pi transmitter? Cheers.hikerrobot

  • Are you saying you are having a problem on the transmit side? If so what software are you sing to do the transmission? – joan Oct 29 '19 at 20:48
  • Shucks, forgot to mention that! Also, I'm away with work at the moment hence the lack of actual codes, process output etc. I have used the Python rpi-rf transmit script and the pigpio software. There's a script called 433.py which is provided by the pigpio authors. This is mentioned on the securipi link I sent above. – hikerrobot Oct 29 '19 at 20:59
  • This is just a rant, I see no Question! You have a couple of links, but not told us what YOU tried – Milliways Oct 30 '19 at 0:23
  • 1
    Ok. Fair point. I will edit the original post when I am back in the company of my Raspberry pi's. Apologies. – hikerrobot Oct 30 '19 at 9:04
  • Shouldn't it be possible to receive the signal that the transmitter sends, all using the Pi? – hikerrobot Oct 31 '19 at 8:34
0

Not an absolute answer, since there could be any number of issues, possibly overlapping.

1) Those modules are awful, place them close together or add a better antenna. They will most likely not pierce even a drywall obstacle.

2) Use a frequency counter at <=5mV sensitivity to verify the TX is actually transmitting. If <=5mV gets flooded, use <=9mV.

3) Use a pair of arduinos with example code to see if TX/RX is ok.

What's worth noting is you don't need to do any encoding for these, you only write to the relevant output and read the relevant input. Have a look at the rpi-tx project if you don't want to buy a frequency counter just for this project.

Update 11/1

Have a look at SDR USB dongles for troubleshooting RF. It can be handled via a graphical interface.

| improve this answer | |
  • Thank you for your input @user2497. I added an antenna to one of my transmitters and have had some sucess. Please see update above, if you're interested. I attempted to go down the rpi-tx route, but so far have been unable to clone the repo. It appears I have fell fowl of an issue with git on Raspbian. It's to do with TLS and some the authentication of the repo. I rebuilt git with a later version, which was suggested as a solution - to no avail. – hikerrobot Nov 1 '19 at 22:58
  • @hikerrobot just get the source – user2497 Nov 1 '19 at 23:01
  • Thanks for the information abour SDR (something I have come across before, but not considered before). And RPI-TX. So, to check I understand the reasons for doing so, I would use RPI-TX to capture the transmission from the socket remote - at which point I could also capture it using a SDR. However, RPI-RX v2 can also replay it again - which gives another opportunity to repeat the transmission. It isn't mentioned anywhere that the transmission is persisted by RPI-TX, but this shouldn't matter as software which works with SDR's can do this I believe. – hikerrobot Nov 2 '19 at 20:04
  • As a next step, I intend to buy a SDR, install software such as SDR#. I also want to try the cheaper 433mhz receiver and transmitter pair. So far I have only tried the more expensive heterodyne kit. I don't as yet appreciate why I am unable to active the socket, as the remote does which came with it, but I am enjoying learning about the additional technology. I am hopeful in closing off this question still, as I still remain convinced that the objective is reachable. – hikerrobot Nov 2 '19 at 20:09
0

Got this working by simply repeating the replay of the signal using codesend. I did, however, use other functions available within rc-switch to view the digital data graph. You can do this by using the raw data and copying it into a webpage which graphs it for you. That is all available in rc-switch.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.