2

I'm using pivpn(OpenVPN) on an rpi3B. When it works it works great, but I'm unable to successfully authenticate more often than not. I've tried it on 2 different wifi networks, with similar results.

Simply, if I can connect OK, there is no issue, and performance is just fine. I can see my home network and access everything that I've tried so far, but a large part of the time, I can't complete the TLS handshake(as per the error message), and almost always I can't reconnect again.

Lets say I connect just fine(using the OpenVPN client), and some time later or even immediately, I disconnect. The next time I try to connect(from the same wifi network and same computer) I'll get the TLS handshake error message, and it trys to reconnect periodically, and never succeeds. I can even reboot the computer, and the results don't change. I can't predict when and if I'll be able to connect successfully.

I'm an experienced computer professional, but I'm far from fluent with Linux, and all I'm looking for right now is some direction in what I should collect as fas as data and logs, and some sequences in how I should be troubleshooting the problem.

I'm not using the default port of 1194, but obviously the router port forwarding appears to function correctly. When the connection is functional, I can even putty into the piVPN server remotely, but I did that just to determine how much access that I had. I use no-ip service to reference my 'public' IP address and that appears to function correctly, but I've no idea how to verify that.

I'm pulling my hair out trying to get this reliable. I can alternately use SoftEtherVPN reliably from either wifi network, so I don't think it's an ISP issue. Some kindly words and some direction would be appreciated. I'll supply whatever data that's requested.

1

You are using pivpn. It is a nice tool but when things doesn't work as expected it mask the OpenVPN setup so it is difficult to examine what is going wrong. In particular for an experienced user but not so familiar with Linux it may be an option to setup OpenVPN step by step by hand to see what may go wrong. You can find a simple setup just for this purpose at Simple openVPN with static keys.

| improve this answer | |
  • So, you want me to re-install OpenVPN manually to verify the tunnel? How does that correlate to the issue that the tunnel works, just not all the time? The setup ALWAYS works when I connect using my Android phone. My local router is currently setup using 192.169.1.X subnet, which I understand may be problematic if I'm using a remote network with the same subnet to connect to my internal network, and I plan on changing my local subnet address to preclude that., I doubt that's related, but I'm going to give it a try before anything else. – crusader27529 Oct 30 '19 at 20:13
  • You asked for "some sequences in how I should be troubleshooting the problem." I haven't thought to replace the installation. But I have learned to troubleshoot not reproducible errors is to reduce complexity to make it reproducible. I would use a spare SD Card for it. With your vague description without any details about your network environment, I don't believe that you will find someone who can tell "you are doing this and that wrong and to fix it you have to do that and this." – Ingo Oct 30 '19 at 23:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.