So I got 2 raspberrys and both are running raspbian. So my wifi adapter is TP-LINK WN725N.

I configured my wifi like this:

    auto lo

iface lo inet loopback
iface eth0 inet dhcp
allow-hotplug wlan0
iface wlan0 inet dhcp

        wpa-ssid "mynetworkid"
        wpa-psk "mynetworkpassword"

From these posts: How to set up WiFi with Raspbian "wheezy"

http://learn.adafruit.com/adafruits-raspberry-pi-lesson-3-network-setup/setting-up-wifi-with-occidentalis

Now my problem is, my wifi on my first raspberry pi works but on my second raspberry pi it doesn't work. I noticed that when I booted my second raspberry pi it says:"failed to start wlan0" and "wlan0:no such device"

lsusb:

Device002:Standard Microsystem Corp.
Device001:Linux foundation 2.0 root hub
Device003:Standard Microsystem Corp.
Device004:USB port HUB
Device005:Realtek Semiconductor Corp.
Device006:SiGma Micro HID controller.
Device007:Elan Microelectronics Corp.

ifconfig -a:

It doesn't give the connection I want

What am I doing wrong and how do I fix this?

  • What's the outputs of these commands on the 2nd Pi ? - ifconfig -a / lsusb / usb-devices / lsmod – Lawrence Nov 4 '13 at 4:08
  • @Lawrence See my edit – Loko Nov 4 '13 at 7:44
  • raspberrypi.stackexchange.com/a/9750/894 - I recently use wicd-curses. Before it was hell setting up WiFi - Now its really easy using that and it has reconnect options and allot of other cool thing. It does install python and a few other things but I rather have all that running than pulling my hair out trying to connect to WiFi. – ppumkin Nov 4 '13 at 11:19
  • @ppumkin I can actually do it fairly easy now. Also I use a different wifi adapter. I wouldn't recommend this wifi adapter. – Loko Jan 14 '14 at 13:56
up vote 8 down vote accepted

I got the answer from the raspberry pi official forum. Thanks to MrEngman

There are two versions of this wifi adaptor. V1 has the driver included in most images, V2 requires you to download and install a driver as it is not included in the Linux images.

It appears you probably have V2 and need to download and install the driver. You can determine the wifi version you have if you use command lsusb. This will list the WN725N V2 as

Bus 001 Device 004: ID 0bda:8179 Realtek Semiconductor Corp.

The important info is the ID 0bda:8179.

If it shows this you need to download the driver. If you use a recent version of Raspbian there are precompiled versions available.

Precompiled versions of the driver are available for Raspbian as follows

for 3.6.11+ #538, #541, #545, #551 and #557 use 8188eu-20130830.tar.gz

for 3.6.11+ #524, #528 or #532 use 8188eu-20130815.tar.gz

for 3.6.11+ #371 up to #520 use 8188eu-20130209.tar.gz

Use command uname -a to determine the version you have e.g.

pi@raspberrypi ~ $ uname -a
Linux raspberrypi 3.6.11+ #551 PREEMPT Mon Sep 30 14:42:10 BST 2013 armv6l GNU/Linux
pi@raspberrypi ~ $

Download and install the driver using the commands

wget https://dl.dropboxusercontent.com/u/80256631/8188eu-2013xxyy.tar.gz <--set data code for driver version above
tar -zxvf 8188eu-2013xxyy.tar.gz                                         <--set data code for driver version above
sudo install -p -m 644 8188eu.ko /lib/modules/3.6.11+/kernel/drivers/net/wireless
sudo insmod /lib/modules/3.6.11+/kernel/drivers/net/wireless/8188eu.ko
sudo depmod -a

You can check if the driver is loaded OK with command ifconfig It should show wlan0 something like

wlan0     Link encap:Ethernet  HWaddr a0:f3:c1:25:7d:28
          inet addr:192.168.16.15  Bcast:192.168.16.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:125431 errors:0 dropped:305 overruns:0 frame:0
          TX packets:5821 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:21001551 (20.0 MiB)  TX bytes:762826 (744.9 KiB)

Again Thanks to: MrEngman on the raspberry pi original forum

Also I had the #474 which needs: 8188eu-20130209.tar.gz

Ran into the same problem a few days back.

Short answer: you need the 8188eu kernel driver for the wireless interface to work.

A bit longer answer based on personal experience: Check the box that came with your product. It should list V2 or V3 somewhere on or near the barcode sticker. That is the revision number. I found out that pre-built drivers posted on the official rPi forums or this repository tend to work very fine with V2, but I did have issues with V3. After building the kernel driver from source(instructions and source can be found on github) my V3 adaptor started working flawlessly.

I also found this blog which features a download for the 8188eu kernel driver allegedly built for V3 but I haven't tested it myself

  • Yeah I posted an answer myself. Which I found from the raspberry Pi forum. I did needed a driver. – Loko Nov 6 '13 at 8:25

It's my config, works fine. But I have a static IP, and dont use crypto on wifi.

auto lo  
iface lo inet loopback

allow-hotplug eth0  
iface eth0 inet dhcp

allow-hotplug wlan0  
iface wlan0 inet static
    address 192.168.1.200  
    netmask 255.255.255.0  
    gateway 192.168.1.100  
    wireless-essid SSID  

iface default inet dhcp

Check which version of system do you have, if 3.10.18+ then check this out.

You should first check if your wifi adapter is recognized and configured using iwconfig. One possibility is that your adapter is not named wlan0 but wlan1 or something.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.