1

I was trying to set up an ad-hoc network on my Raspberry Pi 4 and now the WiFi is not working. If I try to run ifconfig there is no wlan0 interface that shows up. I have also tried to manually change the WiFi settings but it gives the error message "Could not communicate with wpa_supplicant". When I hover my mouse over the WiFi GUI, it gives me the error message "Connection to dhcpcd lost". I have gone through the /etc/network/interfaces file and deleted all the changes that I made to it and rebooted, but still not change. Does anyone else have any ideas on how to fix this?

  • Does anyone else have any ideas on how to fix this? - NO because we don't know what YOU did. – Milliways Nov 6 at 6:35
  • Just plain ifconfig only shows interfaces in an "up" state. To see all interfaces use ifconfig -a or ip link. – goldilocks Nov 6 at 15:20
1

I assume you are using Raspbian. On this, dhcpcd is configured to support normal networking out of the box, e.g. use WiFi in managed mode with hook scripts in /lib/dhcpcd/dhcpcd-hooks/. I'm fairly sure that dhcpcd does not support an ad-hoc network with this configuration so you have to do it all by hand.

I suggest to use systemd-networkd to setup an ad-hoc network because it is strait forward and can do very good "unusual" networking. Look at How to setup an unprotected Ad Hoc (IBSS) Network and if possible with WPA encryption?.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.