1

I setup minidlna (apt-get install minidlna) but it does not index any file in my folder.´

[2013/11/04 02:25:09] minidlna.c:898: warn: Starting MiniDLNA version 1.0.24 [SQLite 3.7.13].
[2013/11/04 02:25:09] minidlna.c:926: warn: Creating new database...
[2013/11/04 02:25:09] minidlna.c:132: error: bind(http): Address already in use
[2013/11/04 02:25:09] minidlna.c:1004: fatal: Failed to open socket for HTTP. EXITING
[2013/11/04 02:25:09] scanner.c:727: warn: Scanning /stor/share-public/Filme
[2013/11/04 02:25:25] upnphttp.c:1054: warn: HTTP Connection closed unexpectedly
[2013/11/04 02:25:33] scanner.c:798: warn: Scanning /stor/share-public/Filme finished (78 files)!
[2013/11/04 02:25:33] scanner.c:727: warn: Scanning /stor/share-public/Bilder
[2013/11/04 02:25:33] scanner.c:798: warn: Scanning /stor/share-public/Bilder finished (78 files)!
[2013/11/04 02:25:33] playlist.c:125: warn: Parsing playlists...

No files show up, nor on the webinterface, nor from devices.. empty folders.

Config is default, but only I changed inotify=no because it lead to errors on yes.

media_dir=V,/stor/share-public/Filme
media_dir=P,/stor/share-public/Bilder

#db_dir=/var/lib/minidlna
#log_dir=/var/log
#log_level=warn
1

I had a similar issue a little while ago.
In the end, I killed minidlna, and then ran the command minidlna -R to rescan everything and then it indexed all my files again.

  • strange but this helped... – Daniel W. Nov 7 '13 at 9:35
  • 1
    This is a solution that does not actually solves the basic issue. Rescanning all data is quite time taking. – Kangkan Sep 28 '14 at 8:34
3

In my case it turned out to be the file /var/cache/minidlna/files.db that was owned by root instead of the user minidlna. I removed the files after stopping minidlna, restarted with a force rescan and that file was rebuilt from the media directory with the correct permissions (owner minidnla), since then no problem!

2

Just had the same issue with some files missing. Turned out to be a permission problem. minidlna runs under a dedicated user account minidlna. It will not list files that it cannot read.

chmod -R o+rX on your media files. Then rescan your library (sudo service minidlna force-restart or sudo -u minidlna minidlna -R). Worked for me.

  • should be force-reload, right? – Ben Oct 5 '18 at 16:24
0

When I had the same problem, which wasn't resolved with the -R option, I solved it by changing name of one of the folders in my video share. (/Share/Video/Horror -> /Share/Video/Horror_t), then running -R.

All of the files in that folder showed up immediately. So I went through and renames all the folders with _t (standing for test) on the end of their name something like Horror_t, Scifi_t, etc. I did another -R and all my videos showed up.

I went back and removed the _t and did the -R command again. And all of the files and folders are showing up again. I'm not sure what caused this. I'm guessing that the server knew about these folders and for some reason didn't want to rescan them, despite the minidlnad -R command. As soon as it saw them as "new" folders it rescanned them and worked perfectly again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.