1

I'm trying to set up raspberry pi for a timelapse. I have installed motion, but i cant get it to start. I have tried to start it as a daemon. It seems to start, but when i run ps aux | grep motion there is no result. Also, when i try to stop it: sudo service motion stop, it just says that there is no process to kill.

When i disable daemon mode and try to run it from command line it just says: illegal instruction.

Any suggestions where to start looking? I have seen in the syslog, but no info about motion.

2

You've installed the wrong version of motion. I'm assuming you're using Raspbian ?
You get the Illegal Instruction error when you've installed Debian ARMHF packages on Raspbian.

You've probably used the wrong repositories to install motion.
If you haven't done much work on the Pi so far, I'd re-flash Raspbian on, and then apt-get install motion again to get the correct version of motion installed.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.