0

I have a problem with RPIO. I am running a face recognition using OpenCV python on Raspberry Pi 3B+.

pi@raspberrypi:~/facerec-pi/code $ sudo python capture-positives.py
     Tradeback (most recent call last):
            File "capture-positives.py", line 14, in <module>
                 import hardware
            File "/home/pi/facerec-pi/code/hardware.py", line 9, in <module>
               from RPIO import PWM
           File "build/bdist.linux-armv7l/egg/RPIO/PWM/__init__.py", line 60, in <module>
           File "build/bdist.linux-armv7l/egg/RPIO/PWM/_PWM.py", line 7, in <module>
           File "build/bdist.linux-armv7l/egg/RPIO/PWM/_PWM.py", line 6, in __bootstrap__
           ImportError: /root/.cache/Python-Eggs/RPIO-2.0.0b1-py2.7-linux-armv7l.egg-tmp/RPIO/PWM/_PWM.so: undefined symbol: makedev

This is what the terminal return after I run the program. I am using the RPOP V2 updated for Pi2, Pi3.

  • Are you sure RPIO was built successfully? What happens if you use it with a very simple script? – joan Nov 13 '19 at 11:53
1

I have the same problem using branch v2 of this RPIO fork (https://github.com/JamesGKent/RPIO/tree/v2) on a Pi Zero W. RPIO builds successfully and the error occurs already when importing PWM from RPIO.

Solution: Include sys/sysmacros.h in file source/c_pwm/mailbox.c was missing.

| improve this answer | |
  • Thank you, I fixed my problem. Do you have any problem using the RPIO afterward? – Thang Nguyen Nov 17 '19 at 0:32
  • Until now, RPIO is working like expected. – manox Nov 18 '19 at 9:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.