1

I have recently (in the last few days) bought a raspberry pi and noIR camera.

I was taking some pictures with it, and it was working fine. Then suddenly, it stopped working after a reboot and gave this error message:

pi@raspberrypi ~ $ raspistill -o image.jpg
mmal: mmal_vc_component_create: failed to create component 'vc.ril.camera' (1:ENOMEM)
mmal: mmal_component_create_core: could not create component 'vc.ril.camera' (1)
mmal: Failed to create camera component
mmal: main: Failed to create camera component
mmal: Camera is not detected. Please check carefully the camera module is installed correctly

I have tried rebooting, adjusting the connecting ribbon (the little red camera light lit up on start up) and re-enabling the camera through raspi-config.

If I wait a little while after the above error message, the raspberry pi becomes unresponsive (I have tried it connected via SSH and RDP).

Can someone help me please?

  • Obviously, check the cables. But it is also possible to zap them with static. – SDsolar Jan 10 '17 at 2:25
  • @SDsolar Yeah, I think at the time I did manage to zap it with static, though I can't see how. It's frighteningly easy to do - Make sure you have a case for your camera, people! – starbeamrainbowlabs Jan 10 '17 at 9:15
4

My experience of this error, other than the ribbon cable coming loose, is there is not enough power available to run the the RPi and camera. Remove any un-needed usb devices or try a different power supply. I have two power supplies rated at 1Amp. With a USB stick that has a light it often gets errors as described, I never have an issue with the other supply.

see trouble shooting section here http://elinux.org/Rpi_Camera_Module

  • The only other device I have plugged in is a wifi dongle. It was using the same power supply it used before, and now it is not working. The light on the camera board comes on during boot, but it can't detect the camera for some reason. – starbeamrainbowlabs Nov 6 '13 at 6:44
  • 1
    Graeme's advice is sound, however. You may not have enough power for the camera and the wifi dongle. Try hard-wiring to your wifi router and removing the dongle. Ensure your power supply is at least 1A. – recantha Nov 6 '13 at 7:31
  • @recantha I get the same error if I hard wire the pi to my router and use a known good power supply. – starbeamrainbowlabs Nov 10 '13 at 9:06
1

I've just spent two weeks banging my head against the same error.

The problem turned out to be the small rectangular pad (labelled "SUNNY"), which was a little bit loose. Make sure you've grounded yourself to avoid static damage to the camera, then push it into place - this tab is actually a rectangular plug that fits into a socket underneath.

  • I have returned the offending camera and got another one, but if it happens again I will try this. Thank you :) – starbeamrainbowlabs Feb 8 '14 at 9:47
1

In my case, the camera was the Arducam Spy Camera. I got the same error as indicated in the question. After trying all the other suggestions, I found that the ribbon cable was not staying firmly in the socket. I added a bit of scotch tape to the back to improve the friction hold, and it started working.

0

Do you use the correct slot? You should use the one close to the ethernet-connection.

Woody

  • 1
    Yes I did - It was working before, but then it stopped working. I was using the same slot all the time. – starbeamrainbowlabs Jan 15 '14 at 17:26
0

With me it was because I had mine connected to a large monitor via HDMI. After connecting it to a touch screen (a lot smaller power pull) the camera worked fine. Hope this helps

  • 1
    I didn't have my raspberry pi connected to a screen at all. However, this could be helpful for future users finding this answer. Why did people downvote this? – starbeamrainbowlabs Nov 18 '16 at 9:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.