1

first of all: I'm new to raspberry

I.ve just bought a raspberry PI 4 together with an EnOcean PI 868 module to set up a house automation system. To make it run I've tried the steps described on the element14 site and also used sudo stty -F /dev/ttyAMA0 57600 + hexdump -C < /dev/ttyAMA0 to see at least a single byte received .. with no success.

Of course I've read about the nessessary setup for PI3 like

  • enabling serial
  • disabling serial console
  • adding dtoverlay=pi3-miniuart-bt to /boot/config.txt

and did so. The only differnece I've seen is in /boot/cmdline.txt: tototrials say 'find a line startiing with wc_otg.lpm_enable=0 and remove console=serial0,115200 but I don't have such al line.

Edit

some more things I've found or tried so far:

  • the EnOcean PI 868 uses serial UART gpio 14 &15 and web research always brings me to these points, which are in genereal related to PI 3B but seem to be true for PI4 too:
  • /dev/ttyAMA0 is by default used for blutooth, /dev/ttyS0 as 'miniuart' for serial
  • you can switch devices by adding dtoverlay=pi3-miniuart-bt to /boot/config.txt
  • /dev/ttyAMA0 is also used for serial if you disable blutooth completely with dtoverlay=pi3-miniuart-bt to /boot/config.txt
  • the simplest way to see if anything is received is by calling stty -F /dev/ttyAMA0 (or ttyS0) 57600 (115200 in other posts) + hexdump -C < /dev/ttyXXX
  • Hi @Ingo Leonhardt, Welcome. Ah, let me see. So my dear Rpi newbie, you have a new 2019 Rpi4 and you are following a 2012, ie, 6 years old tutorial for Rpi2? My suggestion is the following: If you have found two cockroaches in any very outdated tutorial, I mean more than 2 years old, remember what the wise guy Warren Buffett says: cnbc.com/2017/08/30/…. – tlfong01 Nov 17 '19 at 2:54
  • 1
    @tlfong01 thanks for reading my question but unfortunaltely your comment isn't very helpful. In the comments to he tutorial are several comments mentioning concering serial on P3B and from everyting I have found so far this should all york with PI4 as well. – Ingo Leonhardt Nov 17 '19 at 10:42
  • I am sorry that I have not been helpful. If beside the problems you mentioned, the seemingly old tutorial can still be good, I need to look at it again, and make an apology to your and Element14. Actually I have been a huge fan of Element14 Hongkong since the Rpi1 days, and so far I have no complaints, except I always tell them that I am just a poor hobbyist doing Micky Mouse projects, therefore cannot afford their a bit expensive industrial grade products. Happy UART programming and cheers. – tlfong01 Nov 17 '19 at 12:22
1

At least for PI4, if you want to read from EnOcean PI 868 via /dev/ttyS0 you have to enable raw mode too:

stty -F /dev/ttyS0 57600 raw
hexdump -C < /dev/ttyS0 

Shows hex dumps of EnOcean telegrams on stdout

That's a good stating point to write my own implementation

0

Have you had any success with integrating the Enocean components?

One of the few sources of useful information that I have found is the Fhem instructions. Link follows. I would like to add a range of Eltako componets to Domoticz or Homeassistant. Adding a relay, e.g. Eltako fsr61-230V is not an easy, which is unfortunate, especially since there a few manufacturers in addition to Eltako, which provide the full-range of CE certified components that are not based on some propriety software or protocol.

https://wiki.fhem.de/wiki/EnOcean_Starter_Guide#Definition_.2F_Anlernvorgang_.28Teach-In.29

  • This does not seem to solve the problem: it seems to be a discussion – user96931 Dec 23 '19 at 17:39
  • Yes I'm now able to read and interpret enocean telegrams from switches (the only enocean devices I'm using at the moment). I have built my house automation from scratch (lights and roller shutters only). After I was finally able to read from /dev/ttyS0 the rest was not a problem, the official EnOcean documents are quite good. – Ingo Leonhardt Dec 27 '19 at 10:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.