1

I downloaded 2019-09-26-raspbian-buster.img (3.7GB after extraction)

then I used win32diskimager-1.0.0 to burn it on MicroSD card

then on /boot/ I created

ssh file

wpa_supplicant.conf file

with content:

country=PL
update_config=1
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

network={ 
    ssid="MyHomeWifiSSID" 
    psk="p@ssw0rd" 
    key_mgmt=WPA-PSK 
}

then in cmdline.txt I added

ip=10.1.1.134::255.255.255.0

but I'm unable to connect to my Raspberry via Wifi, but everything works fine via cable.

I tried also to scan network with Angry Ip Scanner but it doesn't show my Raspberry when it is on Wifi, but shows normally when it's connected via cable.

Configuration from: wpa_supplicant.conf seems to be applied correctly because file disappeared from /boot/

What can be wrong? Thanks in advance

  • What will the kernel command line option ip=10.1.1.134::255.255.255.0 do? What network interface shall get this ip address? I'm not sure but as far as I know this option has no effect. Please edit your question and add the output of these two commands from the RasPi to it: ip addr and ip route. – Ingo Nov 19 '19 at 18:59
0

Make sure you're using a different IP address for the Wired and the Wireless connections.
If you router sees a different MAC address on the WiFi than the Wired NIC it won't want to give the same IP address out until that DHCP lease has expired.

| improve this answer | |
0

I changed WiFi (from router to phone) and it started working fine

| improve this answer | |
0

If your router has bandwidth options you should try switching between 2.4 and 5ghz as my raspberry sometimes don't want to connect on one or the other.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.