2

I've just installed Raspbian.

Loaded it up with ethernet (led is on).

Everything went smooth for about an hour.

Left it while programming in a text file.

Then the internet went down. tried to ping 8.8.8.8, it says

connect: Network is unreachable

This will go back to normal IF i reboot Raspberry Pi

Power Cable is 5V 1A

  • Are you 100% that rebooting the raspberry pi fixed it? Cause I am having problems with internet that is sometimes going down all of the sudden. (with everything) and I once restarted and I had internet again but it wasn't because I restarted it. It was just coincidental. – Loko Nov 6 '13 at 10:15
  • Try to disconnect usb devices. Set up a ssh access and see if there's any difference. – kursus Nov 6 '13 at 18:51
  • Unusually that the internet goes like that. Can you still ping other devices on the LAN, e.g. the router? – Fred Mar 7 '14 at 7:58
1

I've never noticed the ethernet drop out and I've had it on most of the time for months. But...

The next time this happens, try service networking restart. If that doesn't work, try in order:

service networking stop
dhclient -r
ifconfig eth0 up
dhclient eth0

If that works, leave a comment and I can give you a suggestion for keeping the interface up.

  • i've tried this. still the same error – AFwcxx Nov 20 '13 at 9:15
  • okay, looks like when ethernet drop out, i had to sudo /etc/init.d/networking reload all the time! – AFwcxx Nov 20 '13 at 9:34
0

Are you sure, that you have 5V 1A ? I had the same issue, I had a power cable saying 5V 1A but it just got 5V 0.5A. Try a different power supply and report again :)

  • Confirm. am using android samsung charger. – AFwcxx Nov 6 '13 at 11:06
  • Is the problem solved, or does this happen all over again ? – Baris Kilic Nov 6 '13 at 12:11
  • yeap. it happened again after my last reboot. connection lasts around two hours before it dropped. i tried adding servername 8.8.8.8 in /etc/resolve.conf still, no difference. – AFwcxx Nov 6 '13 at 13:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.