6

I'm running raspbian on my pi and followed this tutorial to get the i2c going. i2cdetect -y 1 used to detect my i2c devices but doesn't anymore. The sensor is connected like this: enter image description here

Could this be a software issue?

  • 4
    Has this been solved? If so, please mark the answer that fixed it as such. We're trying to get this site up to par and the Q:A ratio is really bad. Thanks! – RPiAwesomeness Jan 11 '14 at 4:57
  • What kernel are you using? I found that I have to rmmod i2c_bcm2708; modprobe i2c_bcm2708 with kernel 3.10.28, otherwise i2cdetect doesn't find anything. It worked fine with the 3.6 kernel. – elmicha Feb 2 '14 at 20:32
  • the tip from elmicha (rmmod i2c_bcm2708; modprobe i2c_bcm2708) is still valid on a 4.1.15 kernel. – user41750 Feb 19 '16 at 19:33
2

Could this be a software issue?

If lsmod | grep i2c shows i2c-dev is loaded and you have the device wired as shown, it's pretty unlikely.

I've only used 3.3 V things, but I seem to recall reading certain limitations WRT to 5 V ones; you might want to consider that since you used devices plural.

  • i2c_dev and i2c_bcm2708 is the output. Currently I only have one device at a time attached. – thommie Nov 6 '13 at 15:57
1

Just to make sure,

You have connected VCC to 5v, SDA to SDA, SCL to SCL and GND to GN.

First of all, what do you see when you type i2cdetect -y 1 (assuming you have 2nd version of Raspberry Pi, else type i2cdetect -y 0) ?

Do you see an empty address i2c table ?

If yes, then, According to the documentation here

"There are two operating modes for the SRF02. I2C mode and Serial Mode. This is set with the Mode pin, connected to 0v Ground for Serial Mode and left unconnected (or tied to +5v Vcc) for I2C Mode. "

Have you tried to connect the mode pin to +5volts yet ?

0

All the device not work directly on raspberry pi I2c bus without change, maybe you can try to add/remove the pull-up resistor.

Are you sure the device is adapted to raspberry pi spec ?

sometime you need to remove the pull-up resistor from the device (if you device is for arduino) because the raspberry have pull-up (1k8) integrated and the arduino not.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.