0

We are trying to set up cncjs on a pi that had previously used as a robo pi and ran nginx. We tried "sudo /etc/init.d/nginx stop" but this did not work. We were then advised to use “service nginx stop” but it is asking for a password we don't have. anyway to get around this password? Or maybe a better way to make cncjs work?

0

Assuming sudo works enter the command sudo su.

Then enter the command service nginx stop.

4
  • It might be worth pointing out that this solution will not "deactivate" the service, but only stop it. Restarting the RPi will restart the service again. – SiKing Nov 22 '19 at 16:34
  • Reasonable point, but since "deactivate" does not have an objective technical meaning in this context, it is not clear from the question what the goal is beyond "stopping" it, which is repeated several times in the question. – goldilocks Nov 22 '19 at 22:50
  • My bad; to clarify we would like to deactivate it w/o it restarting when the pi restarts. we don't plan on restarting the Pi but its in a high school work shop so it will definitely get restarted on accident. – tw21 Nov 25 '19 at 17:14
  • 1
    @tw21 Try sudo systemctl disable nginx – joan Nov 25 '19 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.