0

I have a Raspberry Pi 3 B connected to my speakers through a usb soundinterface. It's also connected via usb midi to a masterkeyboard which I use to play piano and doesn't have it's own speakers. On it I installed pulseaudio with avahi modules and avahi so I can use the speakers from my computer two. Pulseaudio is running in system mode as a systemd service. service file looks like this:

[Unit]
Description=PulseAudio system-wide server

[Service]
Type=forking
PIDFile=/var/run/pulse/pid
ExecStart=/usr/bin/pulseaudio --daemonize --system --realtime --log-target=journal
ExecStop=/usr/bin/pulseaudio -k
Restart=on-failure
LimitRTPRIO=1000
LimitNICE=-20

[Install]
WantedBy=multi-user.target

and the pulseaudio config file /etc/pulse/system.pa has this added:

load-module module-native-protocol-tcp auth-ip-acl=127.0.0.0/8;10.0.0.0/8;172.16.0.0/12;192.168.0.0/16;fe80::/10
load-module module-zeroconf-publish

When I first tested it out after configuring my client to show discoverable pulseaudio sinks on the network it showed me my usb soundinterface connected to the raspberry in the gnome sound settings and I clicked on that and it worked.

Now I also have a service for fluidsynth running with this service file

[Unit]
Description=Fluidsynth with piano soundfont
After=sound.target

[Service]
ExecStart=/usr/bin/fluidsynth -is -a pulseaudio -m alsa_seq -g 1.0 Salamander-UltraCompact-JNv3.0.sf2

[Install]
WantedBy=default.target

As soon as I turn that on no sound is getting through from the network client anymore until I turn of the fluidsynth service, though I can still successfully play an mp3 with mpv on the raspberry locally with fluidsynth running. While fluidsynth is running and I try to play something from the network client at the same time the pulseaudio log on the raspberry shows the following message.

Error opening PCM device front:1: Device or resource busy

How do I solve this? I thought Pulseaudio over the network was supposed to work like it does locally playing sound from multiple clients at the same time. Should I change something about the network configuration?

Additional info: The exact same thing happens running a spotifyd service instead of or that the same time as the fluidsynth service, so it seems the problem is any service running locally on the same system as the pulseaudio server preventing remote playback. I tried playing back from two different PCs on the network, one laptop with fedora silverblue running and a tower pc running fedora workstation. Both are able to play sound from the raspberry as long as that isn't running either of the two services.

  • What is the difference between the Unit file for Pulseaudio and the Unit file for fluidsynth? They look identical. – Ingo Nov 21 '19 at 18:52
  • oh thanks, they are identical I copied in the wrong one. – pethil Nov 21 '19 at 21:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.