1

Hello enabling TV the full HDMI option to allow 4K 60 hz, the Raspberry Pi 4 stops connecting to Wifi and after boot the connection is bugging.

Further my wireless keyboard and mouse are connecting poorly as there seems to be signal interference. I need to move next to the Pi to be able to type.

When I disable the TV full HDMI option to allow 4K 60 hz, limiting the 4k to 30hz the Wifi connection immediately is fine. Also the keyboard and mouse is fine.

Can anybody reproduce the same behavior?

4
  • 1
    How is "raspbian 64bit" relevant? if you remove the 64bit flags, does that resolve the problem too? Nov 22, 2019 at 11:21
  • This is unlikely to be reproducible without your particular TV and HDMI cable. Nov 22, 2019 at 11:45
  • Raspbian actually only uses a 64-bit kernel; the rest of the OS is the same as "raspbian 32-bit". So presumably the only difference here is setting arm_64bit=1 in cmdline.txt. If you remove that, does it make any difference? If not, the "64-bit" is a red herring here.
    – goldilocks
    Nov 22, 2019 at 13:52
  • Adding or removing arm_64bit=1 in cmdline.txt does not make any difference. Booting the system either way will result in the WIFI not connecting and the Wireless keyboard experiencing interference. However if I enable the extended "HDMI" functions on the TV after boot .. I can change display mode to 4k 60hz without loosing network. But If I kill X and then re authenticate all goes south again .. It is very odd behaviour.
    – Hein
    Nov 23, 2019 at 11:51

1 Answer 1

1

Issue is solved,

As I noticed that this issue would only a occur during the full system startup with the Samsung televisions: "input Signal Plus" enabled. I believed there to be an issue with the Kernel modules. As it would not occur if I enabled and work normally when enabling "input Signal Plus" after boot.

Please note that I used rpi-update to update the Video driver and the firmware and the kernel which solved this issue. Now the system is working as expected after boot up with "input Signal Plus" enabled but please note rrpi-update is not part of the reggular update process, and as it is providing experimental drivers might break more that it will fix!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.