-1

Volume control says "No volume control on this device" When trying to force output to 3.5 or HDMI in raspi-config, it fails with error "There was an error running option..."

When running update in raspi-config, it says:

ALSA lib conf.c:3956:(snd_config_update_r) Cannot access file /usr/share/alsa/alsa.conf
ALSA lib control.c:1375:(snd_ctl_open_noupdate) Invalid CTL default
amixer: Control default open error: No such file or directory

ALSA lib conf.c:3956:(snd_config_update_r) Cannot access file /usr/share/alsa/alsa.conf
ALSA lib control.c:1375:(snd_ctl_open_noupdate) Invalid CTL default
amixer: Control default open error: No such file or directory

ALSA lib conf.c:3956:(snd_config_update_r) Cannot access file /usr/share/alsa/alsa.conf
ALSA lib control.c:1375:(snd_ctl_open_noupdate) Invalid CTL default
amixer: Control default open error: No such file or directory

Hit:1 http://archive.raspberrypi.org/debian buster InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian buster InRelease
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
raspi-config is already the newest version (20191021).
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libpam-systemd : Depends: systemd (= 241-7~deb10u2+rpi1) but 241-7~deb10u1+rpi1 is to be installed
 systemd : Depends: libsystemd0 (= 241-7~deb10u1+rpi1) but 241-7~deb10u2+rpi1 is to be installed
 udev : Depends: libudev1 (= 241-7~deb10u1+rpi1) but 241-7~deb10u2+rpi1 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
  • 1
    have you run any of the suggested fixes displayed at the bottom of the output? – Jaromanda X Nov 22 '19 at 11:23
  • @JaromandaX I did. I have also reinstalled libasound2-data and the errors are gone, though I still don't have sound and the volume control says "No volume control on this device" – Valya Nov 22 '19 at 11:32
0

Ok, solved the issue by reinstalling libasound2-data and setting up Preferences > Audio Device Settings. You should click Select Controls, choose PCM, and then volume control will be enabled

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.