2

I'm using Raspbian, which runs Pulseaudio 2, which consume a high volume of ressources when working with my Debian sid Pulseaudio 4.

So I try to compile Pulseaudio 4 (official archive) on my raspberry.

The process went well : configure, make and install.

But Pulseaudio won't start, I get a

error while loading shared libraries: libpulsecore-4.0.so
cannot open shared object file: No such file or directory

Pulseaudio 2 was not installed on the system.

How can I fix this ?

  • Did you get to this point after following LFS Pulseaudio? This doesn't work on debian. I think I finally got this working by actually replacing default pulseaudio folders. – kursus Jan 31 '14 at 1:33
1

Does the file libpulsecore-4.0.so exist on your system (locate might not know about it even if it's there, try find instead), if so where is it? If it's in one of the lib folders then running sudo ldconfig may help.

If it isn't in one of the normal lib locations, then you can try setting LD_LIBRARY_PATH to point to the folder that it is before running your program.

If the file doesn't exist at all then you've almost certainly got a build problem somewhere. You may find it easier to try dpkg and build from the source package instead as that will have the correct configuration already set up for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.