1

I have 2 Raspberries. First, one 3B, which, I used for a while, everything works well. Now when I'm started using the 4B also, I encountered an issue. My 4B, doesn't resolve nameservers.

Example: ping: google.ro: Temporary failure in name resolution

After this, I edited /etc/resolv.conf with DNS from Google & Cloudflare. When a system restart is issued, the nameservers disappears.

Also, I compared the 3B IP routes with 4B:

ip route 3B:

default via 10.10.10.1 dev eth0 proto dhcp src 10.10.10.4 metric 202 10.0.0.0/8 dev eth0 proto dhcp scope link src 10.10.10.4 metric 202 10.8.0.0/24 dev tun0 proto kernel scope link src 10.8.0.1

ip route 4B:

default via 10.10.10.1 dev eth0 10.0.0.0/8 dev eth0 proto kernel scope link src 10.10.10.8

ifconfig 3B:

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.10.10.4  netmask 255.0.0.0  broadcast 10.255.255.255
        ether b8:27:eb:d5:8b:54  txqueuelen 1000  (Ethernet)
        RX packets 14302475  bytes 2461322255 (2.2 GiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 18365291  bytes 16016935207 (14.9 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 60685  bytes 35184481 (33.5 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 60685  bytes 35184481 (33.5 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

tun0: flags=4305<UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>  mtu 1500
        inet 10.8.0.1  netmask 255.255.255.0  destination 10.8.0.1
        inet6 fe80::d341:d27d:554b:d2f1  prefixlen 64  scopeid 0x20<link>
        unspec 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  txqueuelen 100  (UNSPEC)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 57  bytes 2722 (2.6 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether b8:27:eb:80:de:01  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

ifconfig 4B:

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.10.10.8  netmask 255.0.0.0  broadcast 10.255.255.255
        ether dc:a6:32:5a:1c:82  txqueuelen 1000  (Ethernet)
        RX packets 168634  bytes 205783944 (196.2 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 102315  bytes 7381750 (7.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 6581  bytes 600498 (586.4 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 6581  bytes 600498 (586.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Also, I saw, my wlan0 interface is missing from ifconfig on 4B.

  • Isn't there a line at the top of /etc/resolv.conf which tells you not to edit it by hand? – Dmitry Grigoryev Nov 26 '19 at 9:12
  • There is a single line in which writes that it was generated # Generated by resolvconf. It doesn't automatically mean it's can't be edited manually. – UGD Nov 26 '19 at 19:19
1

There are important differences between the network setup of the RPi 3B and the RPi 4B. Seems you are using an additional VPN connection on the RPi 3B so it doesn't make sense to compare both setups. You also don't tell us how do you configure the network interfaces of the RPi 4B. Do you use a static ip address? I guess you use default dhcpcd because it overwrites your manual settings in /etc/resolv.conf. You should find out why the dhcp server given in /etc/resolv.conf by DHCP does not work. As you see, changing settings in resolv.conf does not help because they will be overwritten. You can define static dns server entries in /etc/dhcpcd.conf but again, I don't know what interface configuration do you use.

| improve this answer | |
  • After the last restart of RPi B3, also I remained without ipv4 address on my eth0. I can only access by keyboard, also I'm stuck on the login screen. Doesn't want to log in, only refresh the screen. – UGD Nov 26 '19 at 20:36
  • @UGD And now? How do you expect to get help? You should at least provide the missing information. – Ingo Nov 26 '19 at 23:11
  • I resolved the issue by setting a static IP address in /etc/dhcpcd.conf, but this method doesn't resolve the main problem, why DHCP doesn't acquire DNS servers from my router. I don't know where to watch to find the problem. – UGD Dec 3 '19 at 22:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.