Out of nowhere my pi stopped booting. The red led lights up, they a long flash of the green led and then a cycle of 4 green blinks. HDMI screen shows nothing. I tried this with two different SD cards, the seconds one is brand new, flashed with vanilla "2013-09-25-wheezy-raspbian"

this page says that 4 blinks mean "start.elf not launched" and that "If start.elf won't launch, it may be corrupt." but the image I'm using seems fine. I've also tried replacing start.elf with the one from github with the same result.

Multimeter between tp1 and tp2 shows 4.91V

tried setting hdmi_safe=1 in config.txt but nothing changed.

Have I bricked my pi? what else can I try?

  • Correct me if I'm wrong, but you probably haven't bricked it, but instead shorted it out, which may mean that you will need to buy another pi
    – slippery
    Nov 7, 2013 at 23:47
  • @zeldarulez That's very possible... but what could I have shorted out? what do I look for?
    – shoosh
    Nov 8, 2013 at 7:35
  • which action of yours on pi brought it to this situation(if you tell we will not do that) i mean like drawing over current from pins or giving more power supply etc..and etc Nov 8, 2013 at 14:40
  • Try testing tp1 and tp2 for Ohms. If there is a short it will be 0ohm or very close it it.
    – Piotr Kula
    Nov 9, 2013 at 20:31
  • Has your problem been solved? If so, please create a self-answer (click the "Answer and paste in your solution.) We are working on a project to get the RPi SE up to par and it requires answers to be marked. Jan 12, 2014 at 6:34

6 Answers 6


The answer to another question:

Won't boot after removing and inserting the SD Card?

That answer suggests that four green flashes indicates that that loader.bin failed to launch, rather than start.elf. Have you checked that for corruption?

  • Have you read the question asked before posting your answer?
    – shoosh
    Nov 9, 2013 at 1:34

For me the problem was caused by my removing of the line start_x=1 from /boot/config.txt file, and in my firmware there is the file /boot/start_x.elf and not /boot/start.elf.

I solved removing the SD card, load it in an adapter and restore with my laptop the line in config.txt file.


I don't think that you have bricked your Raspberry Pi, it's very resistive to misbehavior.

I had this same behavior on one of my Raspberry Pi's. Do you use two different SD cards? If you do try an older image (before 2013-09-25). Also try the newest version.

Are you using a Raspberry Pi made in UK? If you do it might have these problems you describe.vAre you using a Raspberry Pi with a Samsung or NOOBS SD card adapter? If so, it might have these problems you describe.

I think the best way to fix this (without buying new stuff) is to find an image before 2013-09-25.

You may find this post interesting.

  • I don't see how using an older image would help, or why a Raspberry Pi made in the UK would be a problem...
    – syb0rg
    Jan 12, 2014 at 6:24
  • it makes sense, because I actually had extactly this problem, where a RPi from UK did not accept a SD card adapter, but a RPi make in China did. An older image is more like a try.
    – syss
    Jan 12, 2014 at 21:11

The problem is your sd card corrupted after doing some type of update to the system. Happened to me when i updated an addon then cancelled it. Just reformat it then reinstall the os.


The solution: go to the store I bought it, get a new board :)

  • 10
    This is not Apple, this was just a configuration issue.
    – antivirtel
    Oct 14, 2017 at 19:31
  • 7
    Given the other answers available here, it would be really helpful if this was not marked as the accepted answer, as it would improve this question from a search optimization perspective. May 1, 2018 at 4:37

4 flashes means that loader.bin not launched

  • 3
    This is what Chenmunka suggested in the top answer; do you have any additional information you could add to differentiate your answer?
    – Aurora0001
    Apr 14, 2018 at 16:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.