2

I am using the official 15.3W USB-C Power Supply to power up my Raspberry Pi 4.

I got my self a second Raspberry Pi 4 but I haven't bought the power supply yet. Would I be able to use the Macbook Pro 87W USB-C Power Adapter instead?

I know that some devices only ask for so much current, and the adapter will not give more than that. Not sure if that's the case with RPi 4.

  • Simple answer - try it. You shouldn't do any harm as long as it works to the USB-C spec. Worst case is it won't boot. – Dougie Nov 26 '19 at 17:43
  • Yes, Rpi won't ask more current than it needs. But I heard that Rpi4 does not like Apple's USB-C charger. – tlfong01 Nov 27 '19 at 1:21
2

EDIT NOTE: This is a completely revised answer as my original answer was completely wrong! I deleted the answer when this was called to my attention; I have just "un-deleted" it since revising my answer. Without further ado, here is the revised answer:

Incorrect answer:

It will work. Here's the math:

RPi 4 current requirement: 2.5 A (per the org's spec sheet)

Revised Answer:

It won't work.

The Macbook Pro 87W USB-C Power Adapter has enough power to run the RPi 4B. The specifications printed on the adapter state that its 5.2 volt output is rated at 2.4 Amps.

HOWEVER..., it seems that the Raspberry Pi designers didn't read the USB-C specs, and didn't test their design very well before releasing it to production. This has been reported in several sources, including this post on TechRepublic, and further analyzed in this post by Tyler Ward. Or perhaps, The Foundation simply wanted to sell more of their "official" power supplies for the RPi 4B?

And so despite the fact that the Macbook Pro 87W USB-C Power Adapter (now replaced by the 96W supply) has more than ample power to handle the RPi 4, the RPi 4 is missing hardware that allows it to work with e-marked USB-C cables. A design that is compliant with the USB-C specifications will work with e-marked USB-C cables (more info); unfortunately, the Raspberry Pi 4 will not.

The reasons for this bodge are less important now than the remedies, so let's get on with that.

The (most practical) solutions are:

  1. Buy the "Official" power supply sold by the Raspberry Organization, or

  2. Get a NON e-marked USB-C cable.

I saw no reason to cause the manufacture of yet another "wall wart" that may eventually wind up in a landfill when I've already got enough USB-C cables and chargers. It's a standard - right? And so I didn't buy the "official" power supply when I bought my RPi 4. For me personally, Option 1. is a "no-go" at this point.

For Option 2, Tom's Hardware has conveniently provided a list of USB-C cables they've tested that they claim will work with the RPi 4. Tom's also expressed understanding and compassion for the Raspberry Pi organization. I don't buy it, but to each his own.

I've not tried a different cable yet, but when I do, I'll follow up here with the results. In the meantime, I did try my Macbook Pro USB-C charging cable and 87W power supply. I confirmed that it DOES NOT power up the RPi 4. Also note that after trying my Macbook cable & charger on the RPi 4, I had to unplug and re-plug my power supply before it would charge my Macbook again! Just for grins, I also tried a new-ish USB-C charger made by Apple for an iPhone (18 watts as I read the low-contrast specs printed on the charger) with the same result: the 18 watt charger with Apple charging cable DOES NOT power up the RPi 4.

Follow up:

I obtained an el-cheapo USB-C charging cable (aka NON e-marked cable) from Amazon. I tried this cable with my Macbook Pro 87W USB-C Power Adapter. This combination successfully powered the RPi 4B. I also tried this same cable with Apple's 18 watt iPhone charger. This combination also successfully powered the RPi 4B, and has continued to do so for more than 24 hours as of this writing.

  • Have you tried it? There are many reports of problems due to the faulty Pi4 USB-C implementation. – Milliways Nov 27 '19 at 23:45
  • @Milliways: You are correct. I finally found time to clean this up. – Seamus Dec 23 '19 at 9:01
  • Thanks! So if I got it correctly, it should work as long as I switch to the NON e-marked USB-C cable? The power adapter may remain the one from MacBook – Dino Dec 29 '19 at 14:34
  • @Dino: Yes, the power supply itself is not the issue; it's the cable (see the Follow up section above). TL;DR the USB-C spec, but it appears that the cable is used to signal the power supply what output voltage to suppy. E.g. when you're charging your Macbook, the PS outputs 20 VDC; when it's powering a 5 V (USB2) device, the PS outputs 5 VDC. Non e-marked cables will only allow 5 VDC. – Seamus Dec 30 '19 at 2:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.