I've been trying to get network booting working on the Pi, i'm using a 3B+ so this should work. The Pi is in it's own VLAN with DHCP running from a QNAP NAS in a seperate VLAN, the NAS is also running TFTP, the network switch has the appropriate IP Helper settings. I've confirmed that PXE booting is working using another computer which i'm able to boot from fine. When i try it with the Pi i get nothing on the screen, i can see the DHCP offer from the QNAP DHCP but the Pi never attempts to call the TFTP server.

I've tried this with a number of Pi's all are otherwise working fine if booted from an SD card, i've also tried with a 3B Version 2. I'm certain that PXE booting is working in this configuration as I can boot PXELinux just fine with another type of device it's just the Pi's that don't ever seem to try to talk to the TFTP server.

Any ideas would be welcome

  • 1
    I get my Raspberries to boot via PXE on my Synology but I have no clue about QNAP configuration for PXE. Did you configure DHCP option 43 to be "Raspberry PI Boot" on your QNAP ?
    – framp
    Nov 27, 2019 at 20:41
  • 1
    I have also made PXE boot with RPi 3B+ but have no idea what your problem could be with two VLANs, a router between, and QNAP. But you may have a look at Netbooting multiple “workers” RPi from a “master” RPi for comparison. Maybe you find hint. In the first step I would try with direct connected to the NAS.
    – Ingo
    Nov 27, 2019 at 21:22
  • Please don't answer your question in the question. Instead make an answer. You can just cut and paste the update into the answer. After two days you should accept your own answer. Only this will finish the question and it will not pop up again and again.
    – Ingo
    Nov 28, 2019 at 9:58

1 Answer 1


I finally got it working, i had to move away from using the QNAP as the DHCP server and instead i used DHCP on my switch and configured it with both Option 66 (the TFTP server address) and Option 43 (Set to "Raspberry Pi Boot"). The QNAP didn't provide a good way of setting option 43 (without editing raw config files) which is why it wasn't working before. Option 43 is the key, without the PI seeing this it won't attempt to boot from the network.

furthermore, as i'm running Raspbian buster, the following had to be added to the cmdline.txt file to prevent the bcm2835_v412 module from loading as this prevented the pi from booting fully.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.