1

Ive been trying the get the Arducam 16MP IMX298 Color MIPI Camera Module to work with some I2C controlled LEDS.

Im able to detect the LEDS and controll them perfectly. i2cdetect -y 1 shows 4 addresses that correspond to the 4 LEDS.

Im also able to take pictures with the camera. When plugged in, i2cdetect -y 0 show around 6 addresses that disappear when the camera is unplugged. i2cdetect -y 1 doesnt show any addresses.

The problem is that when both the LEDs and the camera are conntected to the raspberry, the SDA of the I2C channel 1 is pulled low permanantly.

I tried to use a software i2c interface by following the this tutorial: [url]https://planb.nicecupoftea.org/2019/03/27/an-i2c-heat-sensor-with-a-raspberry-pi-camera/[/url]

I still get the same results. everythings fine when either one of the modules are used (LEDs, camera). But i get the same problem when both are plugged in.

Has anyone of you ever encountered this problem?

Cheers

1
  • What is plugged in where? Let's have some photos of your set-up.
    – joan
    Nov 29 '19 at 9:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.