0

I'm trying to move my buster installation from a pi4b 1.2 from the card I borrowed from my brother (32gb samsung evo plus) to a new SanDisk extreme 32gb, both seem to be genuine (or a least of the same speed and size as declared in the packaging) however after I imaged the first one to the write it to the second win32 returns me more space is needed than is available:

required: 62521344 sectors

available: 62333952 sectors

sector size: 512

the extra space DOES appear to contain data.

What can I do? Already tried formatting it in a couple of different filesystems and partition schemes wihtout luck, also tried to click on continue but the pi wouldn't boot with the second sd, rewriting the same image to the first one works just fine, shouldn't 32gb microsds be the same size?

  • Just give your brother the new card. :-) – Bob Brown Dec 4 '19 at 19:21
  • "shouldn't 32gb microsds be the same size" -> Should does not mean are ;) This has been observed here before. – goldilocks Dec 4 '19 at 19:32
  • @BobBrown this wasn't faster I would, he also likes to use only Samsung cards for some reason – Angelo Tognon Dec 4 '19 at 19:33
3

It is quite common for two microSD cards of the same nominal size to have slightly different capacities.

The "SD card copier" function that's part of the "Accessories" sub-menu will compensate for differences in card sizes provided the destination card has room for all the data on the source card. In your case, that should be no trouble at all.

For multiple copies, way to deal with this is to make a master image, set it up to auto-resize on the first boot, then "shrink" it by deleting some of the free space. I don't know of a way to do that on Windows. I've been shrinking 16GB images using a 64GB card on a Raspberry Pi. You can do that using the PiShrink script. I've had trouble with the resize function of PiShrink, so I do it manually, then use the -s of PiShrink to skip the autoexpand step. The manual way to set up auto resize is explained in this answer.

|improve this answer|||||
  • I'm trying the first method, it'll take a while since the non type c reader I had is only USB 2 but I'll definitely report back if it works and if doesn't I'll try pishrink, thanks. – Angelo Tognon Dec 4 '19 at 19:50
  • I just tried it myself. I successfully copied a 16GB card with plenty of free space to an 8GB card. That worked, and the 8GB card boots correctly. I'm going to edit my answer to make that clear. – Bob Brown Dec 4 '19 at 20:09
  • it definitely worked for me too just fine, thanks for the solution and for PiShrink that I might use for backups to lessen upload/download times to drive, really apreciate it – Angelo Tognon Dec 4 '19 at 21:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.