I am trying to set display of raspberry pi model B+ to 5 inch touch screen. I have mounted SD card and changed config.txt file in /boot/config/firmware folder and added following entries.

hdmi_cvt 800 480 60 6 0 0 0

When I boot the raspberry pi, a rainbow splash screen appears followed by black screen and it remain stuck over there. I have followed this tutorial by waveshare for the reference. Where am I going wrong? I need some assistance.

I have followed elecrow's tutorial and updated the 'config.txt' but still no luck:

# uncomment if you get no picture on HDMI for a default "safe" mode

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan


# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border

# uncomment to force a console size. By default it will be display's size minus
# overscan.

# uncomment if hdmi display is not detected and composite is being output

# uncomment to force a specific HDMI mode (this will force VGA)

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display

# uncomment for composite PAL

#uncomment to overclock the arm. 700 MHz is the default.

# Uncomment some or all of these to enable the optional hardware interfaces

# Uncomment this to enable the lirc-rpi module

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)

# Enable DRM VC4 V3D driver on top of the dispmanx display stack

hdmi_cvt 800 480 60 6 0 0 0

# --- added by elecrow-pitft-setup  ---
hdmi_cvt 800 480 60 6 0 0 0
# --- end elecrow-pitft-setup  --
  • Please tag your question with the Raspberry Pi model. If it's Pi 3B like the question title says, use pi-3b or pi-3b+, if you got it right in the body, use pi-b+. Commented Dec 9, 2019 at 11:50
  • 1
    Remove hdmi_safe=1
    – CoderMike
    Commented Dec 12, 2019 at 10:18

2 Answers 2


I was facing the same problem with the Raspberry pi 4 but without the touch screen. When I studied and searched I found that OS was corrupted or was not compatible to run with the Raspberry pi due to the wrong alteration.

I think you are also facing a similar issue.

Please follow this link: https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=258526

Hope this will give you your answer. And if not you can ask there.

  • It was working earlier in 42 inch display from the start, when I made changes in config.txt then the display went off Commented Dec 9, 2019 at 12:00
  • Also, the initial rainbow splash screen was normal when I boot UBUNTU mate Commented Dec 9, 2019 at 12:01
  • Yeah, this happens when we alter config.txt. I have experienced this 2-3 times. I have seen a function in config.txt which renders the screen size automatically for HDMI. Follow this link to know more conf:raspberrypi.org/documentation/configuration/config-txt/video.md
    – Lucifer
    Commented Dec 10, 2019 at 7:26
  • open the file /boot/config.txt Just verify: disable_overscan=1 must be uncommented and with the value 1 these others: #overscan_left=-20 #overscan_right=-20 #overscan_top=-20 #overscan_bottom=-20 must be commented Can also try this: raspberrypiwiki.com/index.php/5_inch_HDMI_GPIO_Touch_Screen elecrow.com/wiki/… youtube.com/watch?v=n1COKzM1FlI
    – Lucifer
    Commented Dec 10, 2019 at 7:32
  • @Lucifier I have followed steps you mentioned and also followed elecrow's link, but still same issue persist :( Commented Dec 17, 2019 at 17:57

I suggest you get a USB to UART dongle and set up your RPi to produce boot messages to serial port. This usually involves editing cmdline.txt to make sure there is a serial console (console=serial0,115200) and there's no quiet parameter. You should be able to collect boot messages on a laptop using Putty or a similar terminal program. Get this working without the screen in the first place.

Then get your screen connected together with the UART. If you can solder, just solder the TX and RX lines on the bottom of the GPIO connector. If not, get a GPIO expansion board which lets you connect the screen and still have access to UART pins. Then check the boot log, and hopefully you'll see where it gets stuck.

And by the way, you didn't follow a Waveshare tutorial. You followed a video which seems to be posted by a youtuber which doesn't seem to be official. Here's the official Waveshare wiki, which I would use instead if I were you.

PS. If your Pi won't boot without the LCD as well, please read this sticky covering most early boot problems.

  • I did followed Waveshare's guidelines. One more thing I cannot see content of config.txt in /etc/config directory. However, it is linked with /etc/config/firmware/config.txt ... is this fine? Commented Dec 10, 2019 at 5:16
  • @user1584253 You're editing the wrong file. You need /boot/config.txt. Commented Dec 13, 2019 at 8:35
  • this file has no content when I try to edit it, and in its properties I can see it is linked with the config.txt file in /et/boot/firmware directory Commented Dec 13, 2019 at 8:59
  • When I plug in SD card in my laptop I see two drives, one is 'system-boot' and other is 'writable'. In writable drive I have config.txt in /boot directory which is linked with /boot/firmware/config.txt file. However, in 'system-boot' I can see config.txt file. So I am editing this file in 'system-boot' Commented Dec 17, 2019 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.