1

I'm trying to use an external HDD for storage on my Raspberry Pi 3B+. The disk is a 0.55A 320GB Western Digital Blue always plugged in, and added to /etc/fstab with defaults,user options. I've checked the disk twice, it works perfectly.

After boot, the disk is functional. I can use it to play the music on it (it's the only use it has). But after a while (idle or not, but idle is more common), the disk's led goes off. Trying to access the disk one way or another brings the led back on but freezes, causing this to be logged in kernel messages: INFO: task usb-storage:237 blocked for more than 120 seconds. The only options to use it again after that occurs are whether to reboot or to plug it off and then back in.

My PSU is a 30W 3USB ports Aukey supposedly able to deliver up to 2.4A per USB port, yet I still get Under-voltage detected! (0x00050005) messages in kernel logs.

The disk is connected to the Pi with a Y USB cable but i've read somewhere it's useless on a raspi ("useless" but it's the only cable I have which makes the disk working on the pi...).

What I tried to do: I've disabled both Wifi & Bluetooth by appending pi3-disable-wifi,pi3-disable-bt to dtoverlay in /boot/config.txt, no mouse, screen or keyboard are connected. Only the USB disk and the ethernet are used. X is disabled, the pi autologs to console. I've also tried to set /sys/module/usbcore/parameters/autosuspend to -1 in order to prevent the disk from going to sleep, without success. I've read about a "high power mode" or max_usb_current=1 but people say it is obsolete so I didn't try it.

I've thought of connecting the other end of the Y (power) directly to another port of the PSU instead of the Pi, is it any good idea ? Otherwise, I could use another Y cable I have (something like that) to power to Pi, making it gain its power from two of the PSU ports. Would it work ?

I'm really open to any suggestion now. Thanks in advance

4

My PSU is a 30W 3USB ports Aukey supposedly able to deliver up to 2.4A per USB port

But that's not really a PSU; it's a battery charger.

USB chargers are generally not intended to be (or sold as) power supplies. This is an important distinction because live electronics without a battery of their own (as opposed to a phone) will draw a rapidly fluctuating amount of current which the charger may not be built to handle well, because it is sort of the opposite of what is desirable with a charger. Hence their voltage may drop under load. Their current rating is simply a maximum and does not promise anything about instantaneous output in a "supply power" scenario. 5V "powerbanks" fare even worse in this department.

The best idea is a PSU that is sold explicitly for powering 5V devices. Anecdotally, another common issue you will find reported here many times is that USB power cables sold, e.g., with phones for charging can also be a culprit: They're fine for charging batteries but many are not so good in the live device context.

Even PSUs sold explicitly as PSUs (sometime even "for the Raspberry Pi") capable of 2.5A are (in my experience) often not good enough for a Pi 3. At least half of the about a dozen supplies I have trigger the low voltage warning (little lighting bold on screen, and Under-voltage detected! in the system log), although the Pi runs fine (without peripherals).

Supplies sold as 5.1 or 5.2V are probably ideal, since this implies they are designed to maintain a steady voltage as a power source.

The disk is connected to the Pi with a Y USB cable

Pretty sure I have read people doing exactly that here; this list is worth skimming:

https://raspberrypi.stackexchange.com/search?q=%22y+cable%22+usb

|improve this answer|||||
  • Ok, thank you for this answer. I'd never imagined there was a difference between PSU & charger, my bad. I just ordered an official RPi PSU from the foundation, at least it should be a little better. With this and the software tweak from Seamus, I should be able to make it work. – corbin-c Dec 8 '19 at 11:58
  • 1
    I am running a Raspberry Pi 3 b+ with a Toshiba Canvio 1 TB usb portable external drive, powered via USB, using a Raspberry Pi official Pi 3 power supply. It has been fine for 18 months. – Michael Harvey Dec 8 '19 at 14:18
3

I power my RPi 3B+ from a PS sold & distributed by "The Foundation" (i.e. has the RPi logo embossed on it). I also have a Western Digital "Passport" USB drive that I've connected to the RPi USB port & use as a file server for my Sonos system. I've never had any power/undervoltage issues.

I'm posting this because it's possible your issue is related to the WD firmware. My "Passport" drive used to malfunction regularly. After some research I found that the "malfunction" was the WD firmware invoking "Power Management". I also learned that Power Management could be disabled in the firmware using WD's "WD Drive Utilities" software. It's available for Windows & Mac - just Google search for the one you need. After disabling "Power Management", I've had no more issues.

|improve this answer|||||
  • I'll try that "WD Drive Utilities" software eventually, thanks for the tip – corbin-c Dec 8 '19 at 11:55
  • 1
    hdparm may also be able to configure this (Western Digital drives are mentioned several times in the man page -- though it also recommends using their software instead if available). – goldilocks Dec 8 '19 at 13:06
  • Well I guess I'll give hdparm a try since my disk is not recognized by the WD Drive Utilities (which handles WD Passport Drives whereas mine is a WD Scorpio Blue) – corbin-c Dec 9 '19 at 8:09
  • I received my official PSU from "The Foundation" and it works like a charm. The HDD goes to sleep when idle and wakes up without problem when needed. hdparm was not necessary. No more under voltage kernel messages ! Thank you guys – corbin-c Dec 15 '19 at 10:33
  • That's good news & thanks for following up. If you feel one of the answers helped solve the problem, please select it with the "check mark". FWIW, I think Goldilocks answer is better than mine - I only added mine 'cause I had some similar issues with WD drives. – Seamus Dec 15 '19 at 14:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.