0

I have a brand new raspberry pi 4, with official power supply. Brand new SD card, just installed the latest Raspbian on it using UNetBootIn on my main linux (Mint 19) machine.

As the display stoically refuses to work, I am attempting to set up my Pi headlessly following this tutorial. I inserted the SD card (after adding a blank ssh file), hooked up the power supply and connected the ethernet cable (brand new, works fine with my other computers) to my router.

However, upon logging in to my router, it appears that it cannot see the Raspberry Pi so I cannot retrieve the IP address needed in step 6 of the aforementioned tutorial - it can see all of my other devices. The Pi appears to be doing something. The red LED is on constantly and the green LED flickers at a steady rhythm.

Typing raspberrypi.local into my browser merely leads me to a google search of that phrase, attempting to ssh directly gives me this:

ssh raspberrypi.local
ssh: Could not resolve hostname raspberrypi.local: Name or service not known

What can I do?

  • Are you sure you have put the ssh file in the boot partition and no the boot folder ? Else, try to reboot your router because maybe your router cannot assign another ip addr (all ip address in ip address range could be used) . – Ephemeral Dec 8 '19 at 19:09
  • 1
    The red LED is power, so "on all the time" makes sense. Is it possible that the rhythm of the green LED is flashing an error code? Have a look at this: elinux.org/… If it's not an error code, then it is indicating SD card I-O activity. – Bob Brown Dec 8 '19 at 20:19
  • @Ephemeral there wasn't a boot partition/folder, I just put it at the root of the filesystem: there aren't any folders on it, only files – Jessica Chambers Dec 8 '19 at 20:50
  • 1
    @JessicaChambers, can you see kernel.img, cmdline.txt files in this directory ?In the tutorial that you specify, the drive on windows is boot (V:) displayed in explorer . Your Linux Mint must have the same partition named 'boot' where you put your ssh empty file. If you have not this partition , check in command line with sudo fdisk -l utility on Mint, if you cannot see any boot partition, try to rewrite the image on the SD with sudo dd bs=1M if=your_image_file_name.img of=/dev/sdx on Mint. If you are good, it can be a network problem see my answer about that. – Ephemeral Dec 9 '19 at 3:53
  • "step 6" of WHAT? – Milliways Dec 9 '19 at 10:46
4

Based on your answer that there wasn't a boot partition, your report that the display doesn't work, and an experiment that I've just conducted, I suspect that UNetbootin doesn't do a proper job of installing Raspbian.

Since you're just getting started, please try this: Get a copy of balenaEtcher and use it to re-flash your microSD card. Try the boot process again, with display and keyboard connected, and see what happens. Etcher will take the .img file which you may already have extracted, but you can feed it the .zip file as downloaded from the Raspberry Pi Foundation, too. It will uncompress on the fly.

Using Etcher is the path of least resistance, but if you don't want to or can't install it, you can flash the image using dd. The Raspberry Pi Foundation has instructions.

Once you have keyboard, display, and mouse working, you can then easily set up headless operation if you like.

The experiment was to flash an SD card using UNetBootin (Windows, not Linux, though) then try to boot a Pi 4. I got no display, red light on, a repeating sequence of four flashes on the green LED. According to this link the four flashes can mean one of a few things. In this case, it is an utterly unreadable SD card.

| improve this answer | |
  • The way I read the question, if the OP could have display and keyboard connected, they would not have to ask. – Andrew Savinykh Dec 9 '19 at 0:06
  • @AndrewSavinykh OP writes, " the display stoically refuses to work..." – Bob Brown Dec 9 '19 at 0:14
  • 1
    OK so I think UNetBootIn must be the cause here- heck, maybe I'll get my display running now. I'll try this after work and report back – Jessica Chambers Dec 9 '19 at 8:36
  • 1
    Don't know if this is the correct answer, but it's a well-written answer :) +1 Welcome! – Seamus Dec 10 '19 at 2:22
  • 1
    @JessicaChambers Sorry for being a pest. I guess try the dd approach. – Bob Brown Dec 10 '19 at 11:48
2

Assuming you have correctly written your image on your SD card, here is schematic about how zeroconf work (as specified by @tpack) if you want contact your raspberry with raspberry.local name. Maybe this can help you better understand. Normally if the OS is correctly written and started RPi must obtain an ip addr on her ethernet interface when you plug your Ethernet cable from your raspberry to your router. If you get this IP address you can communicate directly without needed the mdns name record and associated mdns services/daemons. Somes network 'methods' are used for getting an IP addr (purple notations) from a remoste host located on the same network (for you, your Linux Mint). Also, some firewall block ICMP packet type (use -Pn with nmap for example, you can add -p 22 for checking only hosts with SSH port opened). For Arping tool you must know your RPi M.A.C address.

Possible errors :

  • The image was badly written on SD card.
  • Your router dhcp service have assigned all there ip addr and cannot assign a new ip addr.
  • Problem with AVAHI daemon on RPi : self-assigned ip addr, your are not on the same network of your Linux mint.
  • Problem with AVAHI daemon on Mint : not started, he cannot resolve raspberry.local name record.

Network Zeroconf:

enter image description here

| improve this answer | |
1

The tutorial you reference only enables ssh it does not enable the avahi-daemon (zeroconf) which is what you need if you want to connect via a hostname instead of an IP address. So you'll need the IP address in order to ssh to the pi.

Since you are on Linux Mint, try installing nmap and then scanning your network to find the pi. Substitute the appropriate subnet in the command below. You should be able to determine which one is the pi fairly easily in the output.

nmap -sn -A 192.168.1.0/24

Alternately, log into your router and look in the DHCP client table to find the IP address of the pi.

Once you are logged in via ssh, install avahi:

sudo apt-get install avahi-daemon

If I am not mistaken, it will not require a reboot and then you should be able get directly to the pi:

ssh pi@raspberrypi.local

Also, one other thing you can attempt is to connect the pi wirelessly. Add a file called wpa_supplicant.conf in the root of the SD card (same place as your empty ssh file. Put the following contents in the file, substituing your two letter country code for US and your ssid/pw of course:

country=US
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
    ssid="NETWORK-NAME"
    psk="NETWORK-PASSWORD"
}
| improve this answer | |
  • I did log in to my router, but my Pi wasn't listed there. Will I get a different result with nmap? – Jessica Chambers Dec 8 '19 at 21:07
  • 1
    I suspect @bob-brown may be correct. Seems like your pi is not booting properly. If the pi is not showing up in your routers DHCP table then it is not going to show up with namp either. – tpak Dec 8 '19 at 21:27
  • I can't seem to format comments correctly today so added the wpa_supplicant information to my original answer. – tpak Dec 8 '19 at 21:35
1

You are trying to use an old tutorial for an obsolete OS.

You appear to have installed an (unspecified) Raspbian using an unusual tool, which appears to be designed to create bootable drives from an ISO image.

I suggest you install a current Raspbian using one of the recommended tools.

You can enable ssh headlessly as described in How to set up networking/WiFi

See also https://www.raspberrypi.org/blog/a-security-update-for-raspbian-pixel/

Then if you have problems ask a new question.

| improve this answer | |
0

Based on your description, you have installed a fresh copy of Raspbian. Openssh-server is not enabled by default, so you will not be able to ssh to it until you do.

Also, you need to do "ssh pi@raspberrypi.local", unless you are logging in from a "pi" account from your linux box.

Now, what do you see on your monitor right after you attach power to the Pi? You should see the 4 raspberries. If you do not see this, you have boot issues, and no wonder it's not showing up on the network. A check you can try is to attach power without the SD card present. You should see the green LED on solid. If not, you may have a firmware issue.

I strongly recommend using an attached keyboard or mouse initially, once you get past the booting issue, so that you can configure the Pi (like enabling the ssh server, for example).

I have had trouble initially with some SD cards, especially the 128GB ones. I strongly suggest getting a new 64GB sd card -- they are cheap as sin these days -- and also using the Balena Etcher that was mentioned before.

There have been some reported issues with the UHD display mode interfering with the WiFi. Not sure this is your problem, because you should at least be able to boot into the desktop. For this issue, there is a kernel upgrade once you get things going.

Good luck!!!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.