I try to have some fun with minecraft-pi on a raspberry 4, but I can't get it to work.

  • first I managed to get it up and running on a plain system (latest raspbian), but it wasn't running in a window and I couldn't exit it nor could I switch back to another window (tried tab, alt-tab, alt-f4 etc)
  • then I read switched the monitor resolution (fonts where too small on a 4K display). The result was that mincecraft-pi din't run anymore. A black window popped up for a fraction of a second and that's it. When I started it from the shell, I got a cryptic error message which I tried to google - without any success)
  • I then found a hint to deactivate the GL drivers. Now I get a black window but now minecraft window.

and yes, I also removed minecrapt-pi and re-installed it without success...

Any idea what is going wrong?

PS: error message was

Error of failed request: BadValue (Integer parameter out of range for operation)
Major opcide of failed request: 153 (XFree86-VidModeExtension)
Minor opcode of failed request: 10 (XF86VidModeSwitchToMode)
Value in failed request: 0x380
Serial number of failed request: 137
Current serial number in output stream: 139

Update: apt update& apt upgrade tell me that everything is up to date. In addition, if I put the sd card into a raspi 3, everything works like a charm.

  • 1
    I exactly had this problem before updating the GL drivers. Make sure you have the latest patches installed (run sudo apt update and sudo apt upgrade), and then it should run with GL drivers active. Hint: To get the mouse control back, hit ESC.
    – PMF
    Dec 8, 2019 at 19:52
  • thanx @PMF - I just gave it a try. Both, update and upgrade tell me that everything is up to date. I now also tried to put my sd card into a pi 3 - works like a charm. Maybe I have to switch devices...
    – rdmueller
    Dec 8, 2019 at 21:04

1 Answer 1


Have you switched screen resolution?

I get the exact SAME error if I don't play on the default resolution settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.