1

I have been able to successfully map a USB controller with Raspberry Pi 4 using this tutorial: https://core-electronics.com.au/tutorials/using-usb-and-bluetooth-controllers-with-python.html

I'm now trying to map a Bluetooth device (called "Chubby Buttons") and am running into issues. I am able to connect the Bluetooth Device to the PI (It is showing the device as connected via the Bluetooth icon as well as when running "sudo bluetoothctl". However, when I run "ls /dev/input", only my keyboard (event0) and mouse are shown, not the Bluetooth "event".

Does anyone have any suggestions on how I can get the Bluetooth device to show up as an event so I can map it? Or, is it possible that this device - even though it is paired can't be used with a Pi?

Thank you

  • 1
    What is the result of this bluetoothctl command : info AA:BB:CC:DD:EE:FF when your devices are paired ? (AA:BB:CC:DD:EE:FF is your BT addr of your controller) – Ephemeral Dec 10 '19 at 21:39
  • please fix the broken link to the tutorial – jsotola Dec 11 '19 at 2:21
  • 1
    @Ephemeral I ran the info command and since it showed the appropriate information, I tried running "ls /dev/input" again and it works now as "Event 1". I'm not sure what the initial issue was, but its all good now. Thank you – rpascoe Dec 12 '19 at 14:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.