0

So, I've used all ips i could find to try and connect, yet it won't work. Port 22 is open, and I've set up SSH as well. It says "connection refused" for an error message. It's on Windows 10, through Ethernet. Help would be great. ty in advance.

  • Can you elaborate a bit more on what your setup is? It sounds like you are trying to connect to a headless RasPi on your network from Putty running on a Windows PC? How is the Pi connected to the network? Wireless? Can you run an IP scan to see if it is actually connected (which will also give you a specific IP address to target)? – John S Dec 12 '19 at 0:08
  • SSH on the RasPi usually works pretty well. Can you ping the RasPi IP address and get a response? Did you verify that SSH is definitely enabled on the Pi? If you are connected directly to the Pi via ethernet, does the PC ethernet port have an IP address as well? Are you assigning IP addresses statically? If so are your IP subnets on both devices specified correctly? – John S Dec 12 '19 at 2:39
  • Please edit your question and add the information there instead with comments. There is a link below the question named edit. The question is nearly to be closed (4 votes of 5). – Ingo Dec 15 '19 at 1:35
1

It's been a week, and only now did i realize what i had done wrong. Apparently i accidentally forgot to save the config for SSH preferences, and when I re-enabled them on the rpi's UI for it's config it worked, no human error this time. IP was fine, port was clear.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.