0

I use raspberry pi and QT (version 5.7.1). When I use QT += webenginewidgets , I get an error Project ERROR: Unknown module(s) in QT: webenginewidgets however I try to install

-sudo apt-get install libqt5webkit5-dev
-sudo apt-get install libqt5webengine-data
-sudo apt-get install libqt5webchannel5-dev 

but nothing change for me. how to use QT += webenginewidgets

5
  • What programming language are you trying to use to access "QT += webenginewidgets"? What is the code you're using (an applicable snippet)? What compiler?
    – user96931
    Commented Dec 16, 2019 at 1:39
  • C++, QTcreator, GCC, Raspian Commented Feb 10, 2020 at 11:56
  • So "QT += webenginewidgets" goes in your qmake project file? Do you #include <QtWebEngine>?
    – user96931
    Commented Feb 10, 2020 at 18:05
  • Also, install the requirements listed here: pastebin.com/8gNFVgFA
    – user96931
    Commented Feb 10, 2020 at 18:07
  • yes my code include QtWebEngine Commented Feb 21, 2020 at 20:14

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.