0

PI 4 I've added display_hdmi_rotate=1 to /boot/config.txt and the display rotates. I've also tried =3 with the same results described below.

During boot the Raspberry Pi Desktop welcome splash is centered in the screen.

Once the desktop loads it's as if X is unaware of the change in aspect ratio, and the right half of the screen is off the edge of the monitor, while the bottom half of the monitor is blank.

I've tried changing the disable_overscan setting, I've also tried forcing the framebuffer height and width, but that merely increases the likelihood that X will simply crash. I've upped the memory split to 256.

It seems as if the underlying hardware is on board, but X isn't?

0

This is a known condition. See https://www.raspberrypi.org/forums/viewtopic.php?f=66&t=243717&p=1536871&hilit=rotate#p1536871

You can disable vc4-fkms-v3d. I don't know what impact this may have - the documentation is sketchy.

The Screen Configuration utility has a cunningly hidden Configure/Screens/HDMI-1/Orientation menu.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.