0

It remains stuck on the rainbow screen, and I don't know what to do. I've followed all the steps and I'm still stuck on the rainbow screen. Please help.

7
  • Have you tried un-plugging the Pi and plugging it back in again? Have you installed Raspbian successfully or is this screen before you can even install that? Commented Dec 20, 2019 at 9:14
  • What power supply are you using? Did you install Raspbian directly using Etcher or via Noobs?
    – CoderMike
    Commented Dec 20, 2019 at 9:36
  • 5V-2A power supply and via NOOBS
    – Joss
    Commented Dec 20, 2019 at 9:53
  • @Legendus I've tried that as well. And I've installed Raspbian via NOOBS. I also formatted my SD Card to FAT instead of NTFS. Still not working.
    – Joss
    Commented Dec 20, 2019 at 9:54
  • Recommended power supply is 5.1V 3A raspberrypi.org/products/type-c-power-supply However try flashing 'Raspbian with Desktop' direct to sd card with Etcher raspberrypi.org/downloads/raspbian balena.io/etcher
    – CoderMike
    Commented Dec 20, 2019 at 9:58

1 Answer 1

0
  1. See Pi4 Boot Problems Sticky follow the diagnostics and post any findings. If you get as far as the rainbow screen see The Boot Problems Sticky

  2. Do NOT install NOOBS install Raspbian.

  3. Ignore all the uninformed rubbish about power supplies, unless you see the power warning.

2
  • Ignoring the Raspberry Pi foundations recommended power requirements is bad advise particularly for new users.
    – CoderMike
    Commented Dec 20, 2019 at 14:50
  • @CoderMike The symptoms described by the OP DO NOT indicate power problems, so advice to check power is misleading. The Foundation recommendations indicate the Pi4 will run on 600mA.
    – Milliways
    Commented Dec 21, 2019 at 0:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.