Raspbian 10 buster here. I tried to connect 5GHz WiFi but it didn't ever see the hotspot. I changed WiFi county to US and it worked.

Now Rpi detects the hotspot and can connect to it but connection breaks every 30+- seconds.

It reconnects and loses connection again and so on.

I turned off WiFi power management but it didn't help.

Power source is 5V 2.5A. Router is not far away.

5GHz works with all other devices.

I see many posts with same problem.

Maybe there are people who have solved the problem?

  • Yes, I bought a 2G/5G WiFi router a couple of months ago, hoping that I can ride faster. I happily set up both 2G and 5G networks at home, but disappointedly found that the 5G network is unreliable. So I end up using only the 2G nework. In other words, Rpi I wasted my money. Similarly for BlueZ5. I found Rpi3/4 BlueTooth unreliable, so I bought a couple of BT devices to test out. Disappointedly only one of them is reliable. So I wasted my money again.
    – tlfong01
    Commented Dec 26, 2019 at 2:19
  • i changed wi-fi county to US - are you in the US? Commented Dec 26, 2019 at 3:13
  • @tlfong01 - how is the RPi responsible for your router being unreliable? Commented Dec 26, 2019 at 3:14
  • @Jaromanda X, Ah let me see. I have been using NetGear 2G router for Rpi2/3/4 and had no problems. I was happy and so upgraded to NetGear 2G/5G. I set up 2G/5G at the same time. Then I found buster setup cannot connect to 5G. I tried many time and gave up. Then I tried 2G and everything was smooth. so far, for a couple of months now. My discipline is first blame myself, googled and try all I can find, before giving up.
    – tlfong01
    Commented Dec 26, 2019 at 3:39
  • My experience is that when I finally gave up, 90% is R's fault. Of course this time I can be wrong. Then I will apologize. I think I am the person who apologizes more than 10 times than average users here. I am blaming R this time, because I don't want other newbies wasting time like me. I will be very glad that others can google or find a solution for R/5G. Then I will apologize.
    – tlfong01
    Commented Dec 26, 2019 at 3:42

1 Answer 1



Ah, let me see. I have the same problem connecting 5G WiFi. I am using a good brand WiFi router with 2G and 5G option. I set up at home both a 2G network, and called it my2Gnet, and another 5G network, my5Gnet.

WiFi Setup


Case 1 - Rpi connected to my2Gnet, with and without wired Ethernet connection.

No problem at all. I always see the "Fan like arcs sort of radiating upwards with a dot a the bottom".

Case 2 - Rpi connected to my5Gnet and also wired Ethernet

Problem - The "Arc fan" icon only stays for about two seconds, then changes to "Up down arrow", then after another two seconds, back to "Arc Fan", and the cycle repeats forever.

Conclusion - I googled and learned that the "Arc fan" icon means connected to WiF, and (b) "Up Down arrow" icon means connected to wired Ethernet.

Case 3 - Rpi connected to 5G my5Gnet withOUT wired Ethernet

Problem - The icon repeat cycle becomes "Arc fan" and "Double red arrow", each for two or three seconds.

Conclusion - I know "Double red arrow" means disconnected. So now it is (automatically) repeatedly connected and disconnected.

Case 4 - Rpi NOT connected to anything

Problem - "Double red arrow" for ever. Of course this is not a problem, because I intentionally do not connect Rpi to WiFi or Ethernet.


Root Cause of Rpi Connecting to 5G WiFi Problem

I googled and found that Rpi buster is NOT responsible for the problem. The cause of problem roots back to her ancestor Ubantu who made a mistake or "sin".

Rpi has inherited the original sin.

So my big apology for wrongly accusing the lovely and innocent Rpi baby. :)


See references below.


(1) WiFi signal icon switches to Ethernet icon (up down arrows) after Suspend? - 2017dec

(2) How to restart network on Ubuntu 16.04 Xenial Xerus Linux - 2016apr

(3) 5GHz WiFi keeps disconnecting on Ubuntu 18.04.3 LTS - Ask Ubuntu 2019nov

End of answer

  • I have dual band router 2g and 5g. 2g works and I have situation 3 with 5g: wifi keeps disconnecting. Solution 3 should work only for Ubuntu or for any Linux ?
    – alebasterr
    Commented Dec 27, 2019 at 1:18
  • Well, the Ubuntu 18 Solution 3 guy says that none of the solutions he googled work, and his own new suggestion is not good enough. So he is now waiting for a super guy coming up to bring joy to the whole world. Me anxiously waiting too! :) PS - I always think that if the big brother Ubuntu don't know what to do, What his little sister Rpi (having wasted money for an useless 5G router) can do is weeping in the dark. :)
    – tlfong01
    Commented Dec 27, 2019 at 1:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.