Abandoned post by Unregistered user.

I tried creating a Raspberry Pi VM using the official Raspberry Pi for Desktop iso located at https://www.raspberrypi.org/downloads/raspberry-pi-desktop/, but every time I run the install, I get this message in the VM "An installation step failed. You can try to run the failing item again from the menu, or skip it and choose something else. The failing step is: Install the system." I don't know what I am doing wrong.

I am using Virtual Box and am running Debian 64-bit.

  • is the "pi for desktop" 64bit or 32bit? Commented Dec 26, 2019 at 3:12
  • It says x86, so I assume 64bit. I tried installing both 32 and 64 bit though, same result Commented Dec 26, 2019 at 5:21
  • x86 is 32bit ... 64bit would be x64 or amd64 or something with 64 in it Commented Dec 26, 2019 at 8:52
  • Perhaps you need a different image.
    – user96931
    Commented Dec 27, 2019 at 18:04
  • Abandoned post by Unregistered user.
    – Milliways
    Commented Aug 12, 2023 at 12:20

4 Answers 4


This semi-worked for me:

I arrived back at the first "install" screen after receiving the red error message of death stating the "failing step is: install the system."

At this screen, I selected the VirtualBox's File > Close > "Send the shutdown signal"

enter image description here

This somehow took me to the Raspberry Pi setup screen where you initialize your preferences such as languages.

This doesn't seem like a permanent solution, for after a restart the state doesn't appear to be persisted... but it at least gets you into the OS.

Good luck, I hope this helps someone.


From the install screen, it looks like selecting "Run with persistence" instead of "install" also seems to semi-work.

After restart the install process begins again.

enter image description here


Overcome this problem by initially configuring the virtual machine with 2000MB memory and 15GB disk. Raspberry installation, do it with "Graphical Install" I did this because when I was installing the updates, I got a message saying not having enough space for updates.


I just create the pi desktop image on VirtualBox 6.1.16 64bit using the 32 bit pi image from your link.

Set the VM to be 4 gig ram, 16 gig hard disk, linux OS, 32 bit (1 CPU until after the installation, because I forgot to update it).

Chose the Install option and it went through without a hitch. Rebooted and now I have a full Rasbian desktop in a vm. So these settings should work for you too.


The Solution simply is:

You need VirtualBox 5.2 !!! newer Versions of Vbox dont support 32bit Systems.

Oracle: "Please also use version 5.2 if you still need support for 32-bit hosts, as this has been discontinued in 6.0."

get it at: https://www.virtualbox.org/wiki/Download_Old_Builds_5_2

greetz DangerMouse

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.