2

I am using Raspberry Pi 4 model B, with Raspbian v 10 buster.

I was following this tutorial to set up TensorFlow object detection on my Raspberry Pi and PsEye camera.

The problem is, when I try to install libatlas-base-dev I get an error:

pi@raspberrypi:~/tensor_flow $ sudo apt-get install libatlas-base-dev

Reading package lists... Done

Building dependency tree

Reading state information... Done

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies: libatlas-base-dev : Depends: libatlas3-base (= 3.10.3-8+rpi1) but it is not going to be installed E: Unable to correct problems, you have held broken packages.

I've tried sudo apt-update and sudo apt-get -f install without any luck. I am able to install most of other software.

I also tried sudo apt-get install libatlas3-base with the following error:

The following packages have unmet dependencies:

libatlas3-base : Depends: libblas-common but it is not installable

So I also tried sudo apt-get install libblas-common with further errors:

E: Unable to locate package libatlas-common

  • Unable to locate package libatlas-common that's the cause of the whole problem - that's what you need to investigate ... it's odd that you try to install libblas-common and it says libatlas-common can't be found – Jaromanda X Dec 26 '19 at 3:05
  • 1
    on further investigation, seems libblas-common exists in jessie and stretch but not in buster - looks like the tutorial you followed is too old for pi4 (which requires buster) – Jaromanda X Dec 26 '19 at 3:10
  • @JaromandaX that's very unfortunate. But help for your investigation! Do you know if it is possible to use tensorflow to detect objects on buster? – PolGraphic Dec 26 '19 at 3:18
  • no idea - perhaps search for tensorflow on raspberry pi 4 - see if there's any tutorials on how to install it on the pi4 – Jaromanda X Dec 26 '19 at 3:19
  • 1
    There's something wrong with your apt setup in that case - libatlas3-base depends on libc6 (>= 2.27), libgcc1 (>= 1:4.0), libgfortran5 in raspbian buster - have you added sources to your apt settings - perhaps you could show your /etc/apt/sources.list file, and any files in /etc/apt/sources.list.d – Jaromanda X Dec 26 '19 at 23:41
2

Thanks to @Jaromanda X I now know that the problem was due to wrong apt setup.

To be precise, some libraries still do not support buster and in case of Snips (for offline speech detection), the suggested workaround was to switch to stretch repository for it (namely, https://raspbian.snips.ai/stretch).

After doing so, while trying to install libatlas-base-dev, which in buster should no longer depends on libblas-common, due to https://raspbian.snips.ai/stretch I was actually trying to get the older version which was still using it. And of course, after longer time I forgot I've added this deb in the first place.

So the way to go was to remove it from /etc/apt/sources.list.d.

Credits to @Jaromanda X for finding the source of the problem.

  • 1
    I'm not expert with it, but you can use apt pinning (I think) to have your snips come from https://raspbian.snips.ai/stretch and not effect the system like that – Jaromanda X Dec 27 '19 at 0:05
  • @JaromandaX that's actually sweet! ;) I was thinking about first installing the snips this "dirty way" than disabling the stretch deb (in case I would have to re-do the installation)... but I prefer the way with apt pinning much better and will look into it. – PolGraphic Dec 27 '19 at 0:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.