0

I've recently modified my boot/config.txt to include the following lines:

dtoverlay=gpio-poweroff,gpiopin=9,active_low=n
dtoverlay=gpio-poweroff,gpiopin=10,active_low=n

This works exactly how I wanted, but I noticed that the ACT-LED doesn't blink 4x during the shutdown sequence and the POWER-LED doesn't stay on after shutdown. Does this mean that the raspberry pi didn't shut down properly?

4
  • please describe what problem you are having
    – jsotola
    Dec 27 '19 at 4:23
  • Raspberry pi normally shuts down with the ACT-LED (green) blinking 4-5 times and the POWER-LED (red) stays solid until you remove the 5V power source. After modifying my config.txt, I noticed that neither green nor red LEDs are on during shutdown (power is still connected). I am concerned that me modifying the config.txt file might somehow cause the RPI's power to turn off prematurely and possibly lead to corrupt SD card over time. Is my fear correct?
    – Philip C
    Dec 27 '19 at 4:34
  • Raspberry pi normally shuts down with the ACT-LED (green) blinking 4-5 times ... if by "4-5 times" you mean 10 times, then you're correct Dec 27 '19 at 11:08
  • My mistake, yes it does normally blink 10 times. Again, after modifying my boot/config.txt, none of this happens and both LEDs are not on during the shutdown sequence. Is this healthy for the SD card?
    – Philip C
    Dec 27 '19 at 22:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.