We did following steps:

  • Installed Linux version 4.19.75-v7+ on SD card.
  • Have two DS18B20 connected to the pi (via terminal block).
  • We are using 3v3 ground and GPIO 4.Enabled 1 wire
  • 4.7K Ohm resistor is connected between the 3V red and the communications yellow wires.
  • Executed: sudo modprobe w1-gpio sudo modprobe w1-therm
  • Tried adding following lines to the /boot/config.txt:

    /etc/modules rtc-ds18b20 w1-therm strong_pullup=1

On checking the /sys/bus/w1/devices folder, we would expect the device numbers (starting with 28) to display. However it shows "w1Master". Not sure if i am missing anything here.

enter image description here

  • The images are too small to make out much detail. You appear to be using 3V3, ground, and GPIO 4. Do you have a pull-up to 3V3 connected to GPIO 4? Have you enabled the 1-wire bus? – joan Dec 27 '19 at 15:30
  • 2
    Welcome, but "We have tried all the possible options..." implies that there is nothing left to be done. Whether that's true depends on what "everything" here refers to, but you have not gone into any detail. Meaning this is implicitly a request for other people to waste their time recommending things that you've already done. Instead, we require that you spend your time explaining in detail what you have tried, what results you expected, and what actually happened. – goldilocks Dec 27 '19 at 18:48
  • If that is unclear, have a look at raspberrypi.meta.stackexchange.com/questions/2197/… – goldilocks Dec 27 '19 at 18:49
  • Hi @Rheal, Welcome and nice to meet you. You might find the following Q&As helpful: (1) raspberrypi.stackexchange.com/questions/102078/… (2) raspberrypi.stackexchange.com/questions/100203/…. Happy temperatujre sensing and cheers! :) – tlfong01 Dec 28 '19 at 1:39
  • Any help is appreciated – Rheal Jan 14 '20 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.