1

I am trying to create a system where USB on Raspberry Pi will be auto mounted and the files can be accessed via an Apache server running over local hotspot from the same Raspberry Pi through a script written in PHP.

I am successful in all the steps and file names are visible via a local hotspot except that when the files are accessed, it is showing a 404 error.

  • The index.php is located on /var/www/html/index.php
  • The files are located on /media/usb0

I have tried changing the file permission to 777 (just to check) but nothing worked for me.

Is there a solution?

2
  • I have found it necessary to change the permissions on each file.
    – Wendall
    Dec 27, 2019 at 22:36
  • Isn't it accomplished by sudo chmod -R /foldername? I tried the same but no luck.
    – pramodcera
    Dec 27, 2019 at 23:04

2 Answers 2

1

I found the solution myself.

The trick is: linking the the two folders by a symbolic link Opening terminal from within the "files" folder (/var/www/html/files on the Pi), and type:

sudo ln -s /media/usb1

(I was running pmount to automount and allocate the name usb1 to any USB attached to Pi.

1
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year.
    – Ingo
    Jan 28, 2020 at 21:33
-1

Bonjour,

Comment as-tu fais pour l'étape 1 ? je cherche à faire pareil.

Merci par avance pour ta réponse,

Jordane GUYONNET

2
  • You are not supposed to ask questions as an answer. If anything, create your own question.
    – LilData777
    Aug 29, 2023 at 12:37
  • please write the answer in english
    – jsotola
    Aug 30, 2023 at 21:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.