-1

I'm trying to work with a Benewake TFMini Plus Lidar sensor in a RaspberryPi. I'm using a USB-2-TTL serial adaptor, which is working properly according to the tests I've ran.

I'm testing the sensor in my Windows 7 pc, and I'm observing the following:

  1. The drivers for the USB-2-TTL adaptor are well installed. My Pc is recognizing properly the adaptor in COM4
  2. The sensor shows a red light, which means that is conveniently wired and receiving power
  3. I'm using Benewake's software for Lidar testing in PC. But the Lidar seems not to be transmitting anything at all.
  4. I've tried also with a python script and nothing happens

Did anyone experienced a similar issue?

Thanks

5
  • 1
    how does a communication problem between a lidar module and a PC have anything to do with a Raspberry Pi?
    – jsotola
    Commented Dec 29, 2019 at 18:21
  • 1
    You're right jsotola. Actualy, this lidar module is to be used with a raspberry pi. Let me know what would be more accurate tags and I'll change Commented Dec 29, 2019 at 20:46
  • a different tag makes no difference since you are posting at the wrong site ... delete your question and ask at electronics.stackexchange.com/questions ... also, please ask a real question, not one that can be answered with a yes or no
    – jsotola
    Commented Dec 29, 2019 at 20:48
  • Hi @JacquesGodin, Welcome and nice to meet you. My answer to the following Rpi LIDAR question might help: raspberrypi.stackexchange.com/questions/102375/…. You might like to let us know which references or instructable you are following. You might also like to list the Benewake python code here and we can try help debugging.
    – tlfong01
    Commented Dec 30, 2019 at 3:15
  • Or is your buster Thonny python 3.7.3 LIDAR code using the following import statements? "import board", "import busio". They are usually for CircuitPython and very likely NOT compatible with Rpi
    – tlfong01
    Commented Dec 30, 2019 at 3:21

1 Answer 1

0

thanks a lot for the reference. Cool stuff, I'll have a look. Meanwhile, I found a way to start reading the TFMini signal. I'm using the following script:

ser = serial.Serial(
        port="/dev/ttyUSB0",
        baudrate = 115200,
        parity=serial.PARITY_NONE,
        stopbits=serial.STOPBITS_ONE,
        bytesize=serial.EIGHTBITS,
        timeout=1
)

while 1:
        x=ser.readline()
        print(x)

It works perfectly. I've managed to do the same in my Windows 7 PC, changing port to port='COM4', the one I'm using. For the latter, this tutorial was very useful: [https://eli.thegreenplace.net/2009/07/30/setting-up-python-to-work-with-the-serial-port1

I'm still not able to use Benewake's testing software, but I've reached out to Benewake's support and I'm waiting for their answer.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.