2

I am trying to receive configure an IR remote control for my raspberry and I configured LIRC on the Pi and it works all fine but I won't be able to capture some output with

mode2 -d /dev/lirc0 

I tried irw as well. I added these lines in /etc/lirc/lircd.conf

driver          = default
device          = /dev/lirc0

/boot/config.txt got this line

dtoverlay=gpio-ir,gpio_in_pin=23,gpio_out_pin=24

The receiver must be connected correctly and there's a red LED turned on. I also tried :ir-keytable

Found /sys/class/rc/rc0/ (/dev/input/event0) with:
    Name: gpio_ir_recv
    Driver: gpio_ir_recv, table: rc-rc6-mce
    LIRC device: /dev/lirc0
    Attached BPF protocols: Die angeforderte Funktion ist nicht implementiert
    Supported kernel protocols: lirc rc-5 rc-5-sz jvc sony nec sanyo mce_kbd rc-6 sharp xmp imon 
    Enabled kernel protocols: lirc 
    bus: 25, vendor/product: 0001:0001, version: 0x0100
    Repeat delay = 500 ms, repeat period = 125 ms
  • Hi @Chris, Welcome and nice to meet you. This "Mode 2 not working" is LIRC newbie' sorrow. You might find my answers to similar questions helpful: (1) raspberrypi.stackexchange.com/questions/103452/… (2) raspberrypi.stackexchange.com/questions/104554/… (3) raspberrypi.stackexchange.com/questions/99823/…. Happy New Year and Lircing. Cheers – tlfong01 Dec 31 '19 at 0:47
  • I' have recognized that the data pin of the receiver is sending a permanent high (5V) when I connected it to an ordinary LED and it didn't react on any of my IR remotes could it be that the problem is just the receiver which might be broken? Because I the configuration have to be correct I checked them a hundred times. – Chris Dec 31 '19 at 10:40
  • yes, perhaps receiver is bad, deside driver uptdated. There are 101 ways to troubleshoot. You find at least a couple of, in my answers. – tlfong01 Jan 1 at 0:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.