0

Updated my screen res to 1080p using sudo raspi-config. After a reboot, VNC is still showing it as the same old small box.

I have disabled overscan but can't really find any information on this issue.

How would I go about forcing an update to the screen resolution?

Thanks!

1

The Raspbian Buster Screen Configuration utility has a cunningly hidden Configure/Screens/HDMI-1/Resolution menu.

This seems to set the GUI resolution independently of the resolution set in Command Mode (at least on Pi4).

The good thing is that it can be changed in real time on a running Pi (at least on Pi4). The bad thing is that it seems to set resolution, ignoring screen specific settings in config.txt.

I have not been able to find any documentation on this utility. I just tried on a Pi3B+ and it isn't present, so it must be Pi4 only.

I haven't yet tried on VNC.

| improve this answer | |
  • That worked, thank you! I was looking in the screen config tool but didn't manage to find anything. Thanks so much for the help! – Giacomo Jan 2 at 23:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.