1

My project, unfortunately, was affected by the release of the raspberry 4 and buster. My script shows on my clients' tv advertising videos with subtitles resized and positioned ad hoc and with a fixed 720p resolution for any type of TV.

The command it executes is:

omxplayer --display=5 -o hdmi --win "0 0 1280 720" --layer 2 --blank --vol -80 --no-ghost-box --align center --font-size 45 --font /usr/share/fonts/truetype/freefont/FreeSansBold.ttf --no-keys video.mp4

For now, the omxplayer distribution for buster has bugs and subtitles are disabled. In fact, running the command with Raspberry pi 4 shows this error:

omxplayer.bin: OMXPlayerSubtitles.h: 86: bool OMXPlayerSubtitles :: GetUseExternalSubtitles (): Assertion `m_open 'failed.

There is no way to solve it for now. So since some of my customers have already purchased the RPi4 I find myself with this headache.

These are the questions:

1) Which player can I use that works with the same command line on both RPi123 and RPi4, Raspian Stretch/Buster?

2) And what is its syntax to achieve the same result as the command with omxplayer?

Thanks in advance.

1

I had the same issue. The media file had a subtitle file with the same name up to the extension.

I made a new directory and created a symlink to the media file only, then played the symlink and it worked without issue.

Weird stuff

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.