1

I'm having some problems with Raspberry Pi 4... The wifi works normally when I use 1920 x 1080.

But when I change the resolution from 1920 x 1080 to 1280 x 720, the wifi suddenly disconnected and unable to connect...

At my wpa_supplicant.conf , the update_config=1 I change it into update_config=0 nothing happens...

I tried to back to 1920 x 1080 to do the following task :

sudo apt-get update
sudo apt-get upgrade -y
sudo apt-get dist-upgrade -y
sudo apt-get install rpi-update -y
sudo rpi-update
sudo apt-get purge rpi-update -y

sudo apt autoremove -y

and the wifi still works normally. But when I back to 1280 x 720 become disconnected and unable to connect to any wifi...

I Even try using: sudo systemctl enable networking still no luck...

my current eeprom VL805 : up-to-date and version 137ab

But when I tried to return the resolution to 1920 x 1080 it works just fine...

But when I change the resolution to 1280 x 720 back to wifi disconnected...

Seems that there are wifi issues on Raspberry Pi 4 for wifi when changing resolution beside 1920 x 1080...

Any idea how to fix it?

PS : I use original raspberry micro hdmi cable and original raspberry charger.

  • I'm using Raspberry Pi 4 Model B 4gb . And I have 2 identical units with the same problem... – Sidhi Ciang Jan 4 at 10:52
  • > "In normal circumstances there is NEVER a need to run rpi-update as it always gets you to the leading edge firmware and kernel and because that may be a testing version it could leave your RPi unbootable". raspberrypi.org/forums/viewtopic.php?p=916911#p916911 Even the rpi-update documentation now warns "Even on Raspbian you should only use this with a good reason. This gets you the latest bleeding edge kernel/firmware." – Milliways Jan 4 at 11:45
  • You claim to have changed resolution - HOW? You have fiddled with networking - WHY? – Milliways Jan 4 at 11:48
  • well, in my case, rpi-update works just fine and still the wifi works well in 1920x1080, but wifi did not work in 1280x720.... I also try the rpi-eeprom-update and still nothing... – Sidhi Ciang Jan 4 at 11:49
  • 1
    "Any idea how to fix it?" Yes - either restore from your backup or do a fresh installation. – Milliways Jan 4 at 11:50
2

It's weird. Sounds like HDMI signals conflicting with Wifi signals, however, change the cable to another one (better, if it has a shield it'd be better.) and add an external wifi dongle.

If you change the cable, maybe you would realize that it's ok with "1920 x 1080" and it's not with "1280 x 720".

The list below can help you.

1920x1080 working
1600x1200 not working
1680x1050 working
1280x1024 not working if switching from 1600, working if 1440 or 1680
1440x900 working
1280x960 working
1280x800 working
1280x720 not working

Different resolution affected the ping rate and network connectivity.

On the whole, there is plenty of circumstances are related. Try changing the resolution and the HDMI cable, using an original power supply, disconnect any USB3 ports, turn WiFi channel number less than 10, etc, though.

Check this link out.
https://www.raspberrypi.org/forums/viewtopic.php?t=254640

| improve this answer | |
  • Well, my charger and cable I use are originally from raspberry. I tried to replace with my chinese micro hdmi and still the same.... – Sidhi Ciang Jan 4 at 11:52
  • Did you try "working" resolution on the list? – M. Rostami Jan 4 at 12:13
  • yes, I just tried your list. When I change into 1280x800 it works. but the ping rate is very poor.... And seems 1280x720 did not make it... – Sidhi Ciang Jan 4 at 14:59
  • 1
    It's the problem that all RPi 4 users have faced. I've added some possibilities that will help you to solve or deal with the problem. Check the link out. It's much more information. – M. Rostami Jan 4 at 20:24
  • well seems I can only wait for the further update... – Sidhi Ciang Jan 6 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.